Request for Script install

I have tried for three days to get something to work, hoping I could contribute a script - that was a fail…

I’m trying to install an opensource account piece that is web-based called “akaunting”. This is a very robust piece of open source accounting software that I believe would be a great addition to your install scripts.

As a note, I have tried php 7.4, 8.0, 8.1 and 8.2
I continually get a fail after I login the first time.
If i make a new droplet on digitalocean that is solely this piece of software it works great under ubuntu 20.04. Can’t get it to run under virtualmin.

Is this something that you could easily write a script?

This website has some info, I also have the download .zip file available.
Documentation – Developer Portal for Akaunting

Thanks
Matt

Hey, I was able to install Akaunting on my Virtualmin system quite easily.

This URL gives you a zip file that can be used with any shared hosting account:
https://akaunting.com/thank-you

Upload it to a Virtualmin virtual server and install it like you would any other app.

3 Likes

Hmnm must be a setting issue on my end. I don’t have that kind of luck.

You haven’t posted any errors or a description of what went wrong. We can’t help with just “it doesn’t work” (I don’t know if we can help, even with errors or a problem description, but it’s the only way anyone can even try to help).

probably, cause i also installed akaunting twice in the past in virtualmin, without any problems…
it was for evaluation, so removed afterwards…
but iirc, nothing special was needed for it to work…

any virtualhost/apache errors?

Did a fresh install -

Created virtual server - no errors
Rechecked virtualmin config & server config - no errors
created a database
Moved the .zip file into the \public_html directory
unzipped
changed owner to domain (ie. root to md4j.org) recursively
opened a browser - went to the site and ran it.
Get and HTTP 500 error.
back into the shell.
Ran an install script I found as an alternative: “php artisan install --db-name=“accounting” --db-username=“md4j_org” --db-password=“XXXXXXX” --admin-email="matt@4theword.net” --admin-password=“password”

Went to the website again - can login with the above credentials.
After login I get another HTTP 500 error and a blank screen.

I may be missing something or out of order, but I sure can’t figure out what.

I didn’t do this. I use Virtualmin’s file manager, right-click on the archive and uncompress it.

I didn’t do this. I ran the web based installer and filled out the form for the database credentials etc.

Oh, it needs PHP 8.x, so Virtualmin → Server Configuration → PHP Options and select the correct version of PHP.

Got it

Deleted PHP 8.2 (not used for anything anyway)
Restarted virtualmin
Used Virtualmin’s file manager

All worked!!!

something … little somewhere that was missed.
Yet another NOOB issue.

Feel free to delete this thread!

HOWEVER - Do think this is worth and install script!!!

Matt