Remove invalid domain/server

in the dropdown menu where I can select a server virtualmin shows up a weird name I did never create. It shows “144139361420765” as a server.
I already tried to remove it through the GUI and terminal but it always tells me that the domain name is not valid and therefore it cannot delete it.
When I view the server every setting is empty (like domain name, unix user name, …).
This server does not show up in the “List of servers”.

How do I get rid of it and what might have caused this?

Best regards,


It sounds like you’re seeing a bug that Jamie hasn’t been able to track down. It’s been in there for years, but occurs so infrequently that we haven’t been able to determine the cause.

It’s harmless though, and can be fixed by deleting a file.

All you need to do is go into /etc/webmin/virtual-server/domains, and there, delete the file with the number you’re seeing in Virtualmin.

Then restart Webmin.

After that, things should be back to normal.


A ghost in the shell =)

I saw this random bug once but it was deleted automatically when I ran the server config check by Virtualmin. It must be from Virtualmin used as a kind of template or a “scratch” virtual server. This only appear on my instances of CentOs 7 but never occurred on my CentOS 7 minimal instances.

Can you help me on this