Relay access denied (state 14)

First, I have dug and dug, maybe it is the lack of sleep but I cannot find this question answered.

I have just setup a vanilla Debian Etch server, other than SSH I did not install anything prior to installing Virtualmin via the setup script. I have purchased the 100 user license and installed it. I setup one virtual domain and one e-mail user. I have changed nothing from the default setup that I haven’t changed back.

I can send mail out from the webmail interface, I cannot send mail to the one user on the system. There also does not seem to be anything showing up in any logs in regards to the incoming email being rejected and I can telnet to port 25 on my server just fine.

Here is what I get back when sending from GMAIL:

Technical details of permanent failure:
PERM_FAILURE: Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 <>: Relay access denied (state 14).

I have also tried sending from another e-mail account using MSExchange, but it gives me less detail than GMAIL.

I saw another post that mentioned looking at the procmail.log file, it doesn’t exist. So then I found a post that showed an example of procmailrc and it included a line that mine didn’t that stated the path to the logfile, I added that line to no avail. Oh, so that would be the one thing that I haven’t changed back, the procmailrc still looks like this:


VIRTUALMIN=|/etc/webmin/virtual-server/ $LOGNAME

  • ?test "$VIRTUALMIN" != ""

Please help I need to have this working and about 300 email accounts on 70 different domains up and running in the next 30 hours.<br><br>Post edited by: kelceybrackett@itptechs.c, at: 2008/07/12 17:03

Hi there,

Well, if you aren’t seeing anything at the logs, I think the first thing I might verify is that the DNS entry for that host is pointing to the right place – currently, mail going to email addresses at is being delivered to the server at – is that correct?

If so, the next thing I’d do is double-check out your logs, and verify that you see connections from being denied with the error you’re seeing above (Relay access denied) whenever you try to send yourself a test.

Thank you. Due to a massive workload right now I haven’t had the sleep need to think. I had changed the MX record but must not have applied a new serial to it when i reloaded it. In my mind I had it set correctly so I did not check. This was the problem with incoming mail. Now I just need to figure out why it won’t let me send mail from a client pc. It hangs and then asks for username and password, I have “SMTP requires login” checked in the client, and I think I saw a number of articles pertaining to this, if you can point me in the most obvious direction that would be awesome, but I am sure that I will find it sooner or later if you don’t see this post right away.

Thanks again for the answer that I should have already checked.


I’m glad you got your DNS issue taken care of!

As for why the authentication isn’t working, are you saying it prompts you for a username/password but doesn’t accept the one you’re entering?

One thing I’d test is that you can telnet to port 25 from the machine your email client is running on. Some ISP’s block port 25, so you may end up needing to look into some alternate ports to run SMTP authentication from.

I’d also look in your log files and see if any errors are showing up in there, they might offer some insight into what isn’t working.

Ok, I am so used to not having my port 25 traffic blocked that I didn’t think about the fact that I changed ISP’s since the last time I needed it. As soon as I opened a VPN connection to the office everything worked fine.

Thanks for your help. I should have gotten this on my own, but a severe lack of sleep got in the way.