Relay Access Denied On Newly Added Domain Only

OS type and version Ubuntu 22.04.3 LTS (GNU/Linux 5.15.0-88-generic x86_64)
Webmin version 2.101
Usermin version 2.001
Virtualmin version 7.8.2

Hello, I am having an issue with a newly added domain name to my Virtualmin server which has a few domains already added. I am able to successfully externally (and internally) send emails using the other domains, and receive them from the other domains outside of this one which was added a few days ago.

For reference, I am able to receive email to this newly added domain name, but when I try to send it out I get the error message: Failed to send mail : SMTP command rcpt to: <> failed : 554 5.7.1 <>: Relay access denied

The odd part, is that the domains and this one are on the same Virtualmin server using the same IP address - so unsure why STMP thinks that this domain isn’t linked to be able to send mail through itself.

I haven’t had to change any settings to get the other domains to be able to send email successfully, and am unsure why this one has any issues. I have verified that this domain has the option to send/receive email under the settings, has the emails setup correctly, and external DNS is setup correctly to route emails outside in.

First, can you send from Usermin? This sounds like your local client isn’t trying to authenticate.


I have tried with Usermin and received the same error message (I have not tried with an external client, since everything sent would be from internal software telling it to send from the system on it’s behalf). I CAN go into Webmin, Server > Postfix, “User mailboxes”) and select the new domain and an email address, and it will send with any issues.

Thank you!

I’m at a loss. Are you going to Usermin from within Virtualmin or are you opening in another browser on port 20000? At this point I’m just doing wild guesses though because it seems like a strange problem. Almost like something went wrong with the setup of the domain.


Yes I am directly going from Virtualmin, going to the domain name, selecting the “Users”, and selecting the email and clicking the button “Sign into Usermin”.

I agree, although I’m hoping to be able to fix this somehow without having to delete the domain - but if that is the recommended option I can go that route.

is it only sending to that fails?
can the other domains send to this recipient? is starting to get really picky of late

No, it is any domain name that is external. If I email the other domains on the same server, it sends no issue. However, anything external will fail with that error the second I hit “Send” on Usermin.

is the domain listed in postfix

Yes, the domain is listed under Virtual Domains. It also is listed under “General Options”, “What domains to receive mail for” (I added it in there in order to figure out if that would resolve it but it didn’t).

Virtual Domains;

Along with all of the others that work perfectly fine right now.

That should be

I wouldn’t play with that.
The forum has other users having this issue, have you checked there.


Yes I have reset it to that shown and same issue. I’ve searched the forums a lot, and many resulted in the domain not appearing within Virtual Domains (which mine does), the domain not having the email option selected (mine does), using an external client (using Usermin), or DNS issues. The odd part is that others noted they can’t receive or send mail, but I can receive mail just fine.

Starting to think its a bad install, I’ve never had this issue and no else it reporting this.