Reducing memory usage - removing postgresql and clamd

Reducing memory usage

I have a server (Ubuntu Hardy Heron) using Virtualmin 3.78.gpl and I would like to free up some memory by not running postgresql (about 160Mb) and clamd (about 100Mb).


I can’t work out what’s running postgresql. There is no S??postgresql link in /etc/rc2.d, but I have observed that there are 4-5 postgresql processes running, presumably since bootup. Whilst I can stop the processes manually using /etc/init.d/*, I’d like to be able to reboot and not have postgresql running in the first place. Any thoughts?

I remember in older versions of Virtualmin there was a first-time configuration wizard where you could choose whether to run the standalone clamd/clamav or not. Virtualmin on my server doesn’t show me the configuration wizard anymore so … where can I find the equivalent settings to enable/disable standalone clamd/clamav?

Thank you.

If Postgres is going to start on bootup, you’d see an entry for it along the lines of what you’re talking about… some sort of S??postgresql-8.3 related file in your bootup dir.

If it’s not in there, it shouldn’t start on bootup.

You could take a look at what Webmin thinks will start… take a look in Webmin -> System -> Bootup and Shutdown, and make sure Postges isn’t set to start on boot.

As far as the first time installation wizard – that does still come up for any new installations. That’s only available the first time you log in though.

To access the ClamAV features now, you can go into Email Messages -> Spam and Virus Scanning, where you can set “Virus scanning program” to “Standalone scanner (clamscan)”. That will stop it from using the ClamAV daemon, and begin using the command line version. You’ll still need to stop the daemon process once you switch that.



My apologies. You are correct. I rebooted my server and the postgres processes didn’t start up. Seems like I didn’t manually stop the service nor reboot since Virtualmin was first installed even though I did remove the startup link in /etc/rc2.d.

Thank you.