Redirection on the main domain

OS type and version Debian Linux 9
Webmin version 1.991
Virtualmin version 7.0-4
Related packages SUGGESTED

Hi, I updated virtualmin yesterday to the latest version, but suddenly the creation of new subdomains don’t work anymore. I can create the subserver of the subdomain, but they are redirected to the main domain.

I try to explain better the situation.

I create a new webserver


I’ve created a record A “xxxxxx” on the DNS that points to the ip of the server, in the same way I have done until yesterday.

Now, instead of open the website xxxxxxx.domain45.tld, it redirects me to domain1.tld, that is the main domain of the server

How is it possibile? Since yestarday everything work well.

I’ve even tried to clone a virtual server of a subdomain of the same domain yyyyy.domain45.tld, so the settings are the same, but don’t work, while the old subdomain webservers work perfectly.

I just did a quick test and works fine. I’m using Centos 7 with Virtualmin 7.


How did you exactly set up the new domain? Did you have the necessary “setup website for domain” and SSL options checked? if you choose the Virtual Server from the dropdown list, then go to Services > Configure Website, do you see the expected page of settings? And what does the Show Directives page show you for your site config?

Do you have any other wildcard virtualhost settings on the main/primary domain, which might override the new domain?


I used Create Virtual-Sub Server.

PS I didn’t tick ssl setting, just ticked Apache for the test.
Just going out, I can try when I come back.

Oh, this is the source of the problem. If you don’t enable Apache SSL website for a domain and later try accessing it using https, it will use a default domain instead, as there are simply no VirtualHost:443 record for it.

1 Like

I think the problem was related to the problem of APACHE that came out in the last update of virtualmin. Solved the problem, it’s seems resolved even this one… Sorry about it :wink:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.