Redirect all user mail to "Contact email address"

When we create new virtualserver, for example - form have the field:

Contact email address:

  • Administrator’s mailbox
  • Other address…

I select “Other address” and type something like

But mail alias for the virtualserver user ( unix user) is not created, so all mail for this user (cron jobs and other system alers) are stay in the local mailbox that user never checks.

How I can setup that virtualmin automatically creates redirect all virtualserver user mail to it “Contact email address”?

And can I set the default “Contact email address” to Other address and type the default email for new domains? We creates domains for own needs and most of them have the same contact email address.

I have find in “Edit Server Template > Mail for domain” form item “Mail forwarders for new users” but it acts for each user, but I need do the redirect only for virtualserver owner user.

Also here is “Mail aliases for new domains” - it adds aliases, but I need the forward rule, not alias.

Where can I setup mail forwarding?


Whenever you’re creating a new Virtual Server, there’s a section called “IP address and forwarding”. Within there, you can set “Default mail forwarding address”.

Would that do what you’re after?


Oh, very sorry, with many options I became completely blind and didn’t see this item :slight_smile: Thanks!

I try this option, but it isn’t work properly on postfix, how to reproduce:

We have email
and want to receive on it all cron mail from user of new virtualserver.

We press Create Virtual Server, set name to
, set
Default mail forwarding address

Virtualmin creates new server with user
, and adds those aliases to

So, after that all mail to redirects correctly to user, but cron mail sends to, not to, and it isn’t redirects to

For solve this we must create aliases like this:

or maybe like this:

You may be seeing a bug in how it works – my suggestion would be to file a bug report, and in that report, include everything you mentioned in your recent forum post here. Then, Jamie can work with you to figure out what’s going on there :slight_smile:


Yes, this is more the bug that the configuration problem, so I create the bug about this.