Received email address shows username-domain<username@domain> instead of username@domain

I, everything is up and running. I have set virtualmin to setup usernames in the username@domain format. However, when I send an email to gmail, it still shows username-domain username@domain when email is received. So instead of my name showing it shows username-domain. (the “-” is bothering me") I would be ok if it showed username@domain. Is there any way to change this. I assume it’s a setting in the email header somewhere.

When I view the email source:

MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII;
Content-Transfer-Encoding: 7bit
Date: Wed, 27 Jul 2016 17:07:18 +0200
From: “username-domain” username@domain
Subject: testing
X-Sender: username@domain
User-Agent: Roundcube Webmail/1.2.0



What email program are you using to send email?


Roundcube installed as a script in Virtualmin.