Rebundled EC2 GPL AMI instance not an exact copy

hi all

I’ve been running the EC2 GPL version for several months and have successfully bundled and uploaded backup AMIs to Amazon S3. Today I tried running an instance of one of those backups and was able to SSH into it successfully and run Virtualmin successfully.

I ran Re-check Config in Virtualmin and got this error: Failed to open /dev/pts/0 : No such file or directory
I followed the advice give here: http://www.virtualmin.com/node/8947 and ran the command: mount devpts /dev/pts -t devpts
Problem solved. Except…

I’m stuck wondering why I get the default CentOS/Apache index.html page instead of the correct index.php page for my virtual server. I checked all the IP address settings I could find and everything looks similar to the original server the backup instance was copied from. Any ideas what I can try next?

cheers
Rob

been having another try at making my backup EC2 instance run correctly…this may be a clue…

Failed to query Postfix config command to get the current value of parameter : /usr/sbin/postconf: warning: valid_hostname: invalid character 13(decimal): sofway.co.uk? /usr/sbin/postconf: fatal: unable to use my own hostname

I have no idea why the ? character has been added to the end of the hostname - the hostname is showing correctly without the ? everywhere I have checked in Virtualmin.

Apache error logs give this warning: RSA server certificate CommonName (CN) `www.sofway.co.uk’ does NOT match server name!?

These are the only clues I’ve been able to find after hours of checking - I’m still nowhere nearer to understanding why I get the CentOS/Apache test page instead of my usual index page.

has anyone ever rebundled a GPL Virtualmin EC2 instance into an EC2 AMI that successfully or unsuccessfully creates new EC2 instances?

Or am I alone in the dark?

Virtualmin > Server Configuration > Change IP Address > select the option to change to a shared IP address.

Problem solved. When a new instance starts, Amazon allocates a new internal IP address. Once the shared address has been selected and set, the option to change IP address disappears.