ready to shower, but need soap!

hello y’all,

i’m having a nickel of a dime time trying to quarter php-soap into my webmin/virtualmin server.
i’ve tried bribing the server with yum install php-soap. it took the moola and installed soap 5.4 i think.
but that can’t buy me any tortillas because i’m using php7.0. so the version i need is the version that will work with php7.0.

when i check phpinfo for my installation (which has php7.0), no soap is found.
but when i switch the php version to 5.4 and check phpinfo, then i see soap enabled.

i have tried to womanually add extension=’/usr/lib/php/modules/’ to the php.ini file and restarted almighty apache. but it still didn’t accept my prayers.
is there a simpler way of choosing from available php extensions from webmin/virtual interface?

i’m beginning to stink. i need this soap badly. pls help.

pls note:
i have read a few posts on here and elsewhere to no avail, including this one:
i installed virtualmin on centos 7 server that i spun from (joe’s favorite), following this and joe’s video
i really want to use virtualmin to manage all my servers. i believe its a godsend app.
pls help me if u can.


It sounds like you may need to install the PHP 7.x version of the SOAP module. The key is to figure out the package name for the SOAP module you need.

It’s normally something like “php70-soap” or so.

What I’d suggest is to try running this command:

yum search soap | grep php

What output does that return?


hey eric,
thanks for the quick reply.
yes i’ve already tried:
yum install php70-soap , and
yum install php7.0-soap
neither worked.

but now it seems i must have messed something up on the server, because when i run yum search soap | grep php
it returns a scary output:

[root@panel ~]# yum search soap | grep php
error: rpmdb: BDB0113 Thread/process 9901/139878449698624 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 - (-30973)
error: cannot open Packages database in /var/lib/rpm

Error: rpmdb open failed
[root@panel ~]#

something is definitely gone awry.

eric, i will destroy this test server and spin up another one. will report back if i encounter same issue with soap. thanks.


That’s a pretty unusual issue you’re seeing there!

Note though that if you haven’t reset things yet, this solution here might resolve that:

eric to the rescue! yes, that solution fixed my rpmdb issue. thanks a lot for that.
now here’s output of yum search soap | grep php :

php-ZendFramework-Soap.noarch : SOAP web services server part helper php-ZendFramework2-Soap.noarch : Zend Framework 2: SOAP Component php-pear-SOAP.noarch : Simple Object Access Protocol (SOAP) Client/Server for php-soap.x86_64 : A module for PHP applications that use the SOAP protocol php54-php-soap.x86_64 : A module for PHP applications that use the SOAP protocol php55-php-soap.x86_64 : A module for PHP applications that use the SOAP protocol rh-php56-php-soap.x86_64 : A module for PHP applications that use the SOAP rh-php70-php-soap.x86_64 : A module for PHP applications that use the SOAP rh-php71-php-soap.x86_64 : A module for PHP applications that use the SOAP

so now i guess i can do yum install rh-php70-php-soap.x86_64 ?

Yup, if you have PHP 7.0 there, the package “rh-php70-php-soap” would do what you’re after.

This command should do the trick:

yum install rh-php70-php-soap

Note that you can drop the architecture at the end of the package name.