Re-starting DNS server .. .. not running! and Failed to start service : Failed to start BIND

When i create a new virtual server i get one of these error:

Re-starting DNS server … … not running!

and when i tried to turn on the Bind DNS Server i get this:

Failed to start service : Failed to start BIND : Starting named: Error in named configuration: zone localhost.localdomain/IN: loaded serial 0 zone localhost/IN: loaded serial 0 zone loaded serial 0 zone loaded serial 0 zone loaded serial 0 zone loading from master file /var/named/ failed: file not found zone not loaded due to errors. _default/ file not found [FAILED]

I registered my nameservers and directed the nameservers on my domain on godaddy, but can’t get the domain to work on the newly installed virtualmin… can anyone help?

Thank you

It looks like it’s not seeing one of your DNS zone files, “/var/named/”.

Does that file exist on your system?

Also, what output do you receive if you run this command:

find /var -name

[root@host ~]# find /var -name
[root@host ~]#

I went onto to check the nameservers and came by these:

I went into diagnostic view and found out these vital error under my domain for diagnostic view:

Nameserver Availability
Critical! Visitors may not be able to access your site. We could not find any nameservers for your domain.

Web Server Availability
Information: We were unable to communicate with your Web server. Please verify your DNS and Web server are properly configured and accessible from the Internet.

I’m not too sure what is going on.

did you register your nameservers at godaddy or did you just create the ns records …
it looks like webmin thinks your dns is under chroot. From the webmin module you need to disable that, eg set “run under chroot” to none


I was getting a similar bind error with a fresh install of centos 6.3 with virtualmin.

I had selected say as my hostname during setup, later when I created my server in virtualmin, the Bind setup creates a bunch of dns records -

you need to add A record for (your server hostname)

That did the trick for me.