Raspberry pi 4 is out and Virtualmin should have a installer script for it. Support for Raspbian buster would be great.

The New Raspberry pi ( 4 B model) comes with a better processor and more RAM. And, it should be fairly faster than its predecessor.
Although, no support for SATA HDD is bottleneck in terms of storage speeds.

Anyways, with better speed and RAM storage its should be the good solution for hosting site.
Right now (July 2nd, 2019), only OS that supports the hardware is Raspbian Buster ( a Debian based Linux distribution).
In coming days we might see the support for the UBUNTU Server and other A+ grade operating systems for the hardware.

Nontheless, few have tried installing Virtualmin on their Raspberry Pi 2,3 and 3+ models running Raspbian OS.
Virtualmin makes a great match for these low power single board computers running on linux distributions.
An ‘install.sh’ script for ARM processors with Raspbian/Ubuntu Server OS would be helping people who wants to host their site from home.

Okay, so I was able boot to ubuntu 18.04.02 LTS on Raspberry Pi 4.
And, I tried to install Virtualmin through install script. I got following error:
Installing Webmin: [2019-07-11 12:50:09 UTC] [ERROR] Failed with error: 100
[2019-07-11 12:50:09 UTC] [ERROR] Something went wrong. Exiting.
[2019-07-11 12:50:09 UTC] [ERROR] The last few log entries were:

Full error is here:
Installing Webmin [ERROR] Failed with error: 100
[ ✘ ]

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
Made it here…why?
Enabling universe repositories, if not already available: Success.
Spin pid is: 3060
Disabling cdrom: repositories: Success.
Spin pid is: 3079
Cleaning out old metadata: Success.
[2019-07-11 12:50:05 UTC] [DEBUG] Phase 2 of 3: Installation
Spin pid is: 3106
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package webmin
Installing Webmin: [2019-07-11 12:50:09 UTC] [ERROR] Failed with error: 100
[2019-07-11 12:50:09 UTC] [ERROR] Something went wrong. Exiting.
[2019-07-11 12:50:09 UTC] [ERROR] The last few log entries were:

If you really must have it, you can attempt a manual installation on unsupported distributions.


any news for raspian ? manual install take too much step

I would pledge rather for Armbian - it has a broader spectrum of SBCs, I was amazed how well it worked on a 2013 Cubox-I 4Pro for example, great device with otherwise not so great support. It is a great power to resurrect peop… pardon me, ancient ARM devices.

Maybe you could even get Virtualmin or at least Webmin in that easy software installer of theirs?

These are not just some nerdy dreams (even if they are):

  • people trust those devices - they trust them with like their homes security and automation;
  • the exposure would be huge, and the ARM world is getting bigger;
  • think about all the students and the teachers that would hear about your software for the first time;
  • it would give all of them an web interface?
  • why else you ask? well it is pretty standard to run your Nextcloud to say the least on an ARM device, storage mounted via whatever from a NAS/SAN;
  • a few personal subdomains for like stuff could also be easily managed, backed up and such.

Not really, I still don’t see it working.

Not sure if your reply was in context. Anyways, thank you for the reply.