Random crashes.... and no SSL for the panel?

  1. I get random crashes. Powerful VPS, 2 cores, 4GB DDR4, nVME SSD and I get random crashes like every other day or sometimes once a week if I am lucky I get the “error establishing a database connection” if using WordPress, or something else if using something else.

This is happening using Vultr VPS, and I have 11 VPS which do it, and one with cPanel that does not do it, and one headless (EasyEngine) that also does not do it. We tried VestaCP, and when that one crashed (once) it just restarted HTTPd and it did so automatically.

  1. Even after copying SSL to my Panel (I think) I still connect via a non secure connection. Can I fix this in the CLI somehow?


Your VPS has 4 GB RAM so you might have chosen the option in Virtualmin’s Post-Installation Wizard to optimize the system for a large database server. I have found that on non-KVM systems, particularly on OpenVZ ones, this causes the Out Of Memory (OOM) Killer to randomly make the system behave in unexpected and erratic ways, including the kind you describe. Could you check what is triggering the OOM KIller / causing services to fail?

Why the same behaviour is not visible on cPanel and other systems is a matter for another discussion - maybe the services that OOM Killer stops are monitored and restarted by cPanel, not an ideal solution but one which makes the system appear to work flawlessly to the casual admin. Webmin has System and Server Status which could be configured to monitor failed services and restart them automatically, if that is what you really want to do…

Additionally, here is some documentation, in case you wish to tweak the OOM Killer in OpenVZ


The easiest thing to do would be to run Virtualmin’s Post-Installation Wizard again (Virtualmin -> System Setting -> Re-run Installation Wizard) and choose a smaller database server size optimization option.

Quick workaround: If you have successfully applied a SSL certificate to any of the virtual servers (domains) that you host under Virtualmin, you could access the Virtualmin GUI via https://domain.tld:10000

Have you tried Webmin → Webmin Configuration → SSL Encryption to apply the certificate for the hostname?

When I chose the RAM, I chose 1 GB, as that’s what is actually needed for what I was doing. I usually run headless, but Virtualmin is like a gift from the angels, other than the crashing and SSL not redirecting automatically so far.

Where do I look for log files? I used to run this on 512 mb of RAM, and it used to crash daily then, and because they boot back up so quickly once restarted, I would actually run a reboot cron each day at 11pm just so it wouldn’t do it, and it worked! However people began to say "OK, I can afford $5 instead of $2.50 and then 1 GB always worked with the MySQL setting set to 512. Now I jump up to 2, and 4 GB for everyone, and I am still getting the crashes, despite there being less, there should not be any, and using headless actually feels tedious now, plus sometimes customers want to be able to create emails, etc so this is why I ask.

That would work, but I was hoping for an automatic redirect :frowning:

Have you tried this?

Yes, did not work, and not only that, I still can’t get the redirect.

Also I am on KVM, so it’s not openvz in case anyone was wondering. Still crashing, although poking around SSL settings and a few reboots worked for the redirects as mentioned in this forum thread.

But yeah now with the new Virtualmin I noticed way more crashes, way more SSL let’s encrypt issues, and a new issue where MySQL doesn’t want to complete the post install process, but I’ve gotten through everything, except the random crashes, as I still don’t know where the error log is :sweat_smile:

Webmin doesn’t crash. So…no need to look for why it’s crashing, because it doesn’t. :wink:

If it’s stopping, it’s because something is killing it. Memory, hardware, or a user or process sending it a kill signal. Webmin logs are in /var/webmin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.