Quotas problem with bind mounts

Trying to find solution for several hours, but no luck so far. In my VPS setup, I have two disks: smaller one for system and larger for data, so I bind-mount /home to /data/home. However, I can’t make disk quotas work.



/dev/vda3 on / type xfs (rw,relatime,attr2,inode64,usrquota,grpquota)
/dev/vdb on /data type ext4 (rw,relatime,quota,usrquota,grpquota,data=ordered)
/dev/vdb on /home type ext4 (rw,relatime,quota,usrquota,grpquota,data=ordered)

My fstab:

cat /ets/fstab

UUID=0b36e527-3409-4e80-8a6f-d1784f8ea716 / xfs quota,seclabel,inode64,relatime,attr2,grpquota,usrquota,rw 0 0
UUID=cf7e98e7-a2c8-4680-b8e3-86d4ca7d77d4 /boot xfs defaults 0 0
UUID=eecff1e7-77e0-4d14-a0e8-aae7b541cfbb swap swap defaults 0 0
/dev/vdb /data ext4 defaults,quota,grpquota,usrquota,nofail,comment=cloudconfig 0 2
/data/home /home ext4 defaults,bind,quota,grpquota,usrquota 0 0

Originally, it was this way but no difference in behavior:

/dev/vdb /data auto …
/data/home /home none …

Quotas are enabled and active in Disk Quotas module (both / and /data) and I can edit them normally here. However, I cannot edit quotas in Edit Virtual Server, it doesn’t show in the Dashboard and Re-Check Configuration says “Quotas are not enabled on the filesystem /home which contains home directories under /home and email files under /home. Quota editing has been disabled.”

Tried to manually edit /etc/webmin/virtual-server/config and set:


After this Disk Quotas section appear on the Dashboard, but it’s incorrectly calculated (only shows sizes on root partition, basically just databases). Also, re-checking configuration reverts them back to defaults and the warning is annoying. :slight_smile:

Any pointer would be much obliged.

Is it possible that no one solved similar problem?