Quotas not visible when Mailman is not running [Solved]

I hope this posts helps someone else breaking his head over a stupid thing.

The story: I installed a new server. Installed Virtualmin. Restored backup copies of my live server. This server acts as a backup server. In case the live server dies, I’ll restore the backups and continue running. Both the live server and backup server are running the same versions of Debian and the same versions of VM.

Restoring the backups went fine. Just one exception: I was not able to set quota in the virtual server settings. Nor could I see the quota set for users and the used quota. The latter was most annoying. I want to see the use.

There are a zillion posts on Google about this problem. (I read them all). Two main causes: the quota is not enabled on the file system or in Webmin. Or the configuration was not checked. After a VM configuration check the quotas should show up.

They did not.

I re-checked the config a dozen times. But the only error message I got was that mailman was not running. So what? I don’t use mailman and I am looking for quotas. Not mailman.

That is wrong. If you don’t see the quotas, and you have a mailman error, fix mailman. Either by configuring it correctly or by disabling it. Once the mailman error has gone, the quotas re-appear.

So if you tried everything else from the zillion posts and that looks fine, just do not accept that you have a mailman error when checking the config.