Quotas editing has been disabled.

CentOS 6.6

When checking virtualmin configuration I get the message:

“The module could not find the mount point for your home directories filesystem /home. Quotas editing has been disabled.”

OpenVZ second level quotas enabled recently on the VPS, here is the output from mount:

/dev/simfs on / type simfs (rw,relatime,usrquota,grpquota) proc on /proc type proc (rw,relatime) sysfs on /sys type sysfs (rw,relatime) none on /dev type devtmpfs (rw,relatime,mode=755) none on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000) none on /dev/shm type tmpfs (rw,relatime) tmpfs on /tmp type tmpfs (rw,nosuid,noexec,relatime) tmpfs on /tmp type tmpfs (rw,nosuid,noexec,relatime) none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)

In server templates, Disc quotas type is set to Hard (enforced) but this isn’t coming into effect :frowning:

Any ideas? thank you


Ah, OpenVZ can sometimes make quota-usage difficult, or even not work altogether.

What is the output of this command though:

cat /etc/fstab

Here’s the output, thanks:

none /dev/pts devpts rw,gid=5,mode=620 0 0 none /dev/shm tmpfs defaults 0 0 tmpfs /tmp tmpfs noexec,nosuid 0 0 tmpfs /var/tmp tmpfs noexec,nosuid 0 0

I’m new to OpenVZ so I guess / isn’t meant to be in there… this could also be whats wrong I imagine…


Try copying the /etc/mtab file over top of your existing /etc/fstab file.

After doing that, are you then able to enable quotas?


perfect, works now !! thanks a lot!