Quotas do not show up on users list

Hi there.

I have a fresh installation of Virtualmin on Centos 7 with xfs.

Quotas are enabled but I can only modify Quotas from Webmin–> System --> Disk Quotas --> (users) and then choosing each user. But then again the quota does not show up in VirtualMin --> Edit Users. Nor quota neither space used by each user. Furthermore when editing or creating a new user on category Quota and home directory settings only directory option shows up.

Any ideas?

I can see than on the same virtualization environment on an Ubuntu server the quotas show up just fine. This is a really weird behaviour and I have already double checked all other posts to find a solution. Still no clue.

Any news on that?


Still facing this issue on VPS using xfs filesystem. I have enabled quotas from Disk and Network Filesystems and my fstab is shown below.

UUID=3aa4ca19-0bbc-4654-ae4c-b884d9be989c / xfs attr2,grpquota,usrquota,inode64,relatime 0 0
UUID=720c8417-48f9-4db1-a9ca-2b8d18b358fd /boot xfs defaults 0 0
UUID=dd5123cd-ffa7-45c6-a90a-8a7aa042fd04 swap swap defaults 0 0

Still quotas are never enabled. This issue only shows up on xfs partitions. I have tested installations with lvm and ext4 on which quotas are functioning properly.

Any ideas?