Quotas are not enabled on the filesystem

Hello… In a new vps installation, the following error appears in my system control. How can I fix it?

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled

Webmin -> System -> Disk Quotas - [Enable Quotas] but process quotaon must be running.

I have this problem…

Failed to turn on quotas : quotaon: using //aquota.user on /dev/sda1 [/]: No such process quotaon: Quota format not supported in kernel.

Have you kernel with qouta support enabled?

Who knows. we are missing that all important System Information again!

1 Like

If you are running ubuntu you can try with installing the linux-image-extra-virtual package.

Another thing to consider is the type of virtualization used.

LXC, OpenVZ might not work out of the box. In my experience quota works out of the box with KVM and possibly XEN.

Sometimes some provider specific actions might be required, hetzner cloud etc…

I solved it with this command sudo apt install linux-image-extra-virtual

That’s not an error, it’s just a thing that is.

If you’re using an unusual filesystem, the installer may not have been able to figure out how to enable quotas, or it may not support quotas. And, some filesystems require rebooting to enable quotas.

The ubuntu installation was done automatically by contabo. Maybe that’s what you’re saying.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.