Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home

After I updated my servers, there is no more quota service

OS: CentOS Linux 7.8.2003
Webmin: 1.953
Usermin: 1.791
Authentic: 19.52
Kernel: Linux 3.10.0-1127.13.1.el7.x86_64 on x86_64


# virtualmin check-config

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled.


# cat /etc/fstab

UUID=f41e390f-*********** / xfs quota,seclabel,inode64,relatime,attr2,grpquota,usrquota,rw 0 0*


# quotacheck -avd

quotacheck: Skipping /dev/nvme0n1p1 [/]
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.


I applied some suggestions from the forum, but without success, as it was something that happened after the update, I believe it is a problem in the compilation of Webmin.

Why would you think it has anything to do with Webmin? quotacheck says clearly your system doesn’t have quotas enabled on that filesystem. That’s not Webmin.

Before the update, the quota system was active and working. For this reason I am saying that this is a problem with Webmin.

# quota -u ****
Disk quotas for user **** (uid 1001):
Filesystem blocks quota limit grace files quota limit grace
/dev/nvme0n1p1 547364 1048576 1048576 32247 0 0

# quota -g ****
Disk quotas for group **** (gid 1001):
Filesystem blocks quota limit grace files quota limit grace
/dev/nvme0n1p1 757492 1048576 1048576 32644 0 0

Oh, it’s XFS. quotacheck doesn’t work for XFS.

I’m not sure why it wouldn’t detect quotas in Virtualmin, since Webmin seems to recognize it…must be something changed in the detection logic. I’ll have to check in with Jamie.

Thanks Joe, I’m sorry I didn’t point out that this was XFS.

Here are some quota commands for XFS:

# xfs_quota > quota
Disk quotas for User root (0)
Filesystem Blocks Quota Limit Warn/Time Mounted on
/dev/nvme0n1p1 5535996 0 0 00 [0 days] /

# xfs_quota > quota -u ****
Disk quotas for User **** (1001)
Filesystem Blocks Quota Limit Warn/Time Mounted on
/dev/nvme0n1p1 547368 1048576 1048576 00 [--------] /

# xfs_quota > quota -g ****
Disk quotas for Group **** (1001)
Filesystem Blocks Quota Limit Warn/Time Mounted on
/dev/nvme0n1p1 757496 1048576 1048576 00 [--------] /

Were quotas enabled with grub2?

Hi ‘ramin’,

File: /etc/default/grub

GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_SUBMENU=true
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_SERIAL_COMMAND="serial --speed=115200"
GRUB_TIMEOUT=1
GRUB_DEFAULT=saved
GRUB_TERMINAL="serial console"
GRUB_CMDLINE_LINUX="console=tty0 crashkernel=auto console=ttyS0,115200 rootflags=uquota,gquota"

# mount | grep ’ / ’
/dev/nvme0n1p1 on / type xfs (rw,relatime,attr2,inode64,usrquota,grpquota)


# xfs_quota -x -c state
User quota state on / (/dev/nvme0n1p1)
Accounting: ON
Enforcement: ON
Inode: #26163 (6 blocks, 6 extents)
Group quota state on / (/dev/nvme0n1p1)
Accounting: ON
Enforcement: ON
Inode: #26165 (5 blocks, 5 extents)
Project quota state on / (/dev/nvme0n1p1)
Accounting: OFF
Enforcement: OFF
Inode: #26165 (5 blocks, 5 extents)
Blocks grace time: [7 days]
Inodes grace time: [7 days]
Realtime Blocks grace time: [7 days]


# xfs_quota -x -c print
Filesystem Pathname
/ /dev/nvme0n1p1 (uquota, gquota)

Thought I’d ask. I do notice your GRUB_CMDLINE_LINUX line is different than what I’m accustomed to seeing for CentOS 7/8, which is rootflags=usrquota,grpquota.

Maybe it shouldn’t matter but I wonder if changing to usrquota,grpquota and recompiling grub would make a difference in your case.

I appreciate your attention, but nothing you are seeing was done by me, everything was applied by Webmin at the time of installation.

It turns out that in the last update, I am unable to apply quotas through the Webmin interface.

Another issue that should be noted is that I am using XFS.

That’s why I asked, quotas for XFS need to be enabled in grub2. It’s possible the Webmin update modified fstab. Use cat /etc/fstab to make sure it says what grub says. If not, see if rebooting syncs them.

Webmin update would never alter grub configuration or fstab.

Virtualmin installation (the very first time, not updates) does try to enable quotas when it can.

I knew grub was off limits but wasn’t sure about fstab.

Hi,

If you unroll this patch, can you see quotas afterwards?

Restarting Webmin will be required.

That’s not what was suggested. You can’t downgrade Webmin without also downgrading Virtualmin and that whole slew of packages I just rolled out. I don’t recommend it.

1 Like

I applied the changes to the two lines of the “virtual-server-lib-funcs.pl” file and restarted Webmin.

However, I still receive the warning:

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled.

Ilia has a new theory about an earlier patch from Jamie. They’re talking it over in a chat. Hopefully will have it figured out soon.

1 Like

Same problem here after the upgrade! In two different systems. Quotas worked just fine before the update.

Which Webmin version was it before the upgrade?

previous webmin version: 1.942

Can you confirm or deny that it’s an XFS filesystem? We’re trying to narrow down the problem.