Quota is exceeded - unlimited quota is set

maybe one of you has an idea what to do.
I have here on two servers the same issues.

I’m not able to receive emails and to upload stuff online.
In the system check Virtualmin say the quota is exceeded.
Both server and the virtual server have unlimited (or the sever has 160GB) space.

I checked the quota settings for the users via SSH, but it is also unlimited…

Any suggestions what to do?

Best regards.


Can you test for both a user and a group quota?

To do that, log into your server, and run these two commands:

quota -v USERNAME quota -g USERNAME

Sometimes, a quota may not be set for one, but it could be set for the other.


Hey andreychek,
I got the following message:

Filesystem blocks quota limit grace files quota limit grace
/dev/sda3 2683360 0 0 119178 0 0
root@Ubuntu-1004-lucid-64-minimal ~ # quota -g root
Disk quotas for group root (gid 0): none
root@Ubuntu-1004-lucid-64-minimal ~ #

Does this made somehow sense for you?

Hmm, that’s showing quotas for the root user.

Is that the user you’re having quota problems with? That is, when you see quota errors in the logs – which user are those quota errors associated with? You’d want to make sure it was that user you’re looking up.


Hmm, I’m not seeing the cause of your trouble there.

Can you paste in the specific error that you saw that shows a quota issue?

There’s a few areas where quotas could come up though –

  1. When a new top-level Virtual Server is created, that also creates an admin account. That admin account has both a user quota, and a group quota. And all additional users added to this domain can’t exceed the group quota of this admin user.

  2. Each email user has a quota.

You can go into Edit Mail and FTP Users for a domain to see if it shows any email users as being near their quota.


One thing you may want to try is going into Edit Virtual Server, and set “Total server quota” and “Server administrator’s quota” to something high – perhaps 5 or 10GB. After doing that, check and see if email delivery works for you again.

Once it does, you can try setting those to Unlimited again to see if that setting sticks.


Well, you shouldn’t have to reinstall… it’s possible that the quota information just needs reset, or it may be that the issue isn’t related to email specifically.

If you go into Limits and Validation -> Check Disk Quotas, and click “Check Now” – does that cause your used disk quota to change? That should cause it to do a fresh lookup of your quotas.


Go to System Settings-> Accounts Plans and change the Disk quota from the Default Plan which is applied to your server.
Worked for me.