Question: AWS t4g.micro arm64 instance running Ubuntu 20.04

Operating system: Ubuntu
OS version: 20.04.2 LTS (GNU/Linux 5.4.0-1037-aws aarch64)

I recently experimented with installing Virtualmin on an AWS t4g.micro EC2 instance after using a t3.small instance for a while. It runs a single, relatively basic website so the cost savings (was already inexpensive) of the t4g.micro looked good.

I ran the Virtualmin installer in the normal way and to my surprise, it installed fine and I’m now up and running on a t4g.micro instance with no obvious issues. Performance seems definitely improved also compared to the t3 instance ,which is great.

One thing I’ve noticed though is that when I run sudo apt update, I’m getting the following messages:

N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository '
pl/apt virtualmin-focal InRelease' doesn't support architecture 'arm64'
N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository '
pl/apt virtualmin-universal InRelease' doesn't support architecture 'arm64'

It doesn’t seem to be a problem necessarily but I’m curious if it indicates something that could at some point break the install? Also wondering why the message " virtualmin-focal InRelease’ doesn’t support architecture ‘arm64’" when it seems to be running fine for me so surely there is some kind of support for arm64? Sorry if stupid question…

Thanks for providing Virtualmin as open source. It’s really allowed me to try out things I wouldn’t otherwise have been able to, and running Ubuntu with Virtualmin on an ARM processor is kind of mind blowing, especially as it seems to work so well.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.