Putting the main server domain into virtual server

I have a quick question about the setup of VirtualMin domains. I have the main server which has the FQDN of pdx.willamettedata.com. I’ve been wondering if it is necessary to put the main server domain into a virtual server or should I leave it seperate from the other domains I host.

Currently I have it setup as a virtual server but I noticed that some things don’t work right when I do this. Such as I do not get mail for the root user and all my daily logwatch reports are being flagged as spam.

What is the best way to run VirtualMin? I guess I am trying to get ideas from some experts out there.

Thank You


Like yourself, I have the primary domain as a Virtual Server. I tried it the other way on a previous server; this way is much easier :slight_smile:

As for why you aren’t getting messages, or some are being tagged as spam?

For the first – you’ll want to make sure an alias exists for the root user within /etc/aliases, that goes to the email address of your choice.

As for logwatch being flagged as spam?

You could try editing /etc/spamassassin/local.cf, and adding a "trusted_networks" line for your machine, identifying it as legitimate.

Like Eric, my usage of Virtualmin has evolved over the years. In the very early days, it sort of made sense to have a “main” domain that was outside of the control of Virtualmin (and there’s actually a little known mode of operation in Virtualmin to manage non-virtual mailboxes, that’s probably still there for historic reasons, though I don’t think anyone would recommend it today). These days, and for at least the past three or four years, all of the domains I manage are Virtualmin domains–including “virtualmin.com”, and everything is “equal”.

The problems you mention are misconfiguration. It’s easy to end up that way, if you don’t follow the advice we give in the docs of coming up with a subdomain name to use for the server itself, that is not a domain you will use for any virtual host (I use ns1.domain.tld, usually). But, you can also correct the problem by tweaking the Postfix configuration manually a bit. The exact problem is hard to guess without seeing the maillog and the spamassassin headers for the problem emails, though. So, I won’t even venture a guess on what exactly you need to do to correct the problem.

I ended up creating an alias for root in the willamettedata.com virtual server config. The main root alias is commented out in the aliases file but I noticed when I created the root alias. It added a new alias called willamettedata-root pointing to the email address that I want. That seems to work ok.

I will look into adding my IP address into the trusted_networks to see if that resolves the the system emails being tagged as spam. I would think virtualmin would have done that when I installed it but I will check.

Another thing I would like to do is use Squirrelmail for the default webmail interface for all virtual servers. Is there a specific way to do this or do I need to install squirrelmail in each virtual server? I am not a huge fan of usermin.

Regarding Squirrelmail – if you log into Virtualmin, and click System Settings -> Server Templates -> Default Settings, then choose Apache Website from the dropdown, you’ll see options along the lines of “Redirect webmail.domain to Usermin” and “URL for webmail redirect”.

What you could do is get Squirrelmail setup on your default Virtual Host. Once it’s working the way you want (perhaps with an SSL cert and such), setup “URL for webmail redirect” to go to your Squirrelmail URL rather than Usermin.