Proxy with SSL enable

**Operating system: Debian
**OS version: 10
Hello,

I have one server behind firewall which on the same LAN with my virtualmin server. Only virtualmin server facing the internet. I want to access this server (web access) using virtualmin’s ‘proxy website’ feature. This server dont have SSL, but i want to apply SSL for this server through virtualmin using Lets encrypt (means that the communication between virtualmin and this server is not secure, its ok since its only on local network) I tried configure virtualmin and i am able to reach this server, but without success if SSL enable. How to enable SSL for this kind of proxy? Thanks

This post is pretty much same as mine as I’m trying to do the same thing use lets encrypt on a internally hosted ssl service.

Hi @drguild ,
Do you able to make it successful?

Still Trying to figiur it out here.

I did manage to make it work.
I had to enable self signed on the backend and ssl protocols in nginx.
You can see from my site in my thread.

I am using Apache. BTW, u just create self sign cert?

My host is virtualmin so apache, then it goes to the project tracker lxc container to nginx.
A breakdown.

Virtualmin (SSL Lets Encrypt local certificate proxy directive .well-known) >
Proxy to Project Manager running on Nginx >
Project Manager Nginx needs a local certificate backend as it requires SSL for the backend.

Doing this as you can see a user goes to the virtualmin side with the lets encrypt certificate.

I run Proxmox so my Vrtualmin is on a lcx container on 192.168.1.3 and project manager Taiga using Nginx on lxc 192.168.1.5.

So the other server also need to activate SSL, just that it cert is self-signed? Meaning that the connection between virtualmin and that server is also secure even in local LAN.

I will try later, Thank you