ProtectedWebDirectory link not showing up.

I am running VirtualMin3.703, on a CentOS 5.3 machine under Webmin 1.480

My issue is this, I have installed the ProtectedWebDirectory module using Webmin>WebminModules and finding the .htaccess-.htpasswd module under standard modules.

I have “Protected Web Directories (under home directory)” set to YES under VirtualMin>Server Templates>Administrators Webmin modules

That module isn’t showing up at all in my users options. When I go into Webmin Users and look at the user the module doesn’t have a check mark beside it? What am I missing here.

mine doesn’t either, however the user has the module available though to protect their directories. It was always enabled on my box.

It should be in virtualmin - Administration Options - Edit Owner Limits - Allowed capabilities and features, but it seems Jamie forgot it there…I’ll add it to bugreport/feature request.

So are you saying this is happening to you as well? I have to manually go in and check the module in order for it to show up. The server template setup isn’t setting the check mark for that module when it creates a new domain. In addition, I have exported a virtualmin account from virtualmin 3.66 and restored it in 3.7.3 and the setting doesn’t import either. My old server using 3.66 sets the Protect module like it should…seems something funky is going on with 3.703

I just want to verify, are you having to manually set yours to have that module or is it set automatically when you create a new virtual server

I am using the newest flavors of everything including the Protect Folder Module

I dont have to set the module. It is there in the users account. But I have always had it enabled.

If it isn’t enabled and you want to enable it now, this should be possible in the features and plugins section of virtualmin - System Settings - Features and Plugins. However for existing users there would be no option to enable it in virtualmin - Administration Options - Edit Owner Limits - Allowed capabilities and features.

It is also not in the Account Plans, which would be really handy too as you can apply it to many domains at once.

Edit: in the default server template it should be enabled under the Administrators Webmin Module. You can then have any other template take over the settings from the default template

In Virtualmin 3.70 and above, the “Protected Web Directories” module is denied to virtual server owners as it had security issues that could allow access to files owned by root. However, if you have the “Virtualmin Protected Directories” plugin installed (from the wbm-virtualmin-htpasswd RPM or webmin-virtualmin-htpasswd .deb), similar functionality with better security is available under the Services category on the left menu.


where can I get this module so i can replace the prot.web.dir with it? I have looked in the standard modules for webmin to install it.
I have found: htaccess-htpasswd Create .htaccess and htpasswd files to protect web-acessible directories.

When I install the htaccess-htpasswd I get this: Failed to install module from : File does not exist

edit: okay second time around it did install, but it is the infamous protected web directories that we should not use. so in fact it should not install or even completely removed from the repos?.

So it’s not working on the newest version on purpose…Is there a place to download the wbm-virtualmin-htpasswd plugin…

I found that new plugin, once you install it you can activate it under Virtualmin> System Settings>Features and Plugins

thx, i installed it but nothing changed on my box. I must have already got it then with the update to 3.70

If you are on CentOS, Redhat or Fedora, you can install it with the command :
yum install wbm-virtualmin-htpasswd

Or on Debian or Ubuntu, try :
apt-get install webmin-virtualmin-htpasswd

Finally, you can also get the .wbm format package from :