ProFTPD wont start

Like some others, I am having trouble getting ProFTPD to start. I have run through the forums to see if I can’t find a solution to tag onto, and realized it would likely be a more organized approach to start a new thread.

My suspicion, though I hope this is not misleading, is that a previous install of vsftpd is conflicting with ProFTPD. I have removed the connection between vsFTPD and port 21, but I still get no love with the ProFTPD connection.

Here are the details:

Trying to connect using FTP on licenced client software “Fetch”.

When I click start server it just returns this:
“Failed to start FTP server : Starting proftpd: [FAILED]”
… and no other data.

I am using:
CentOS release 6.8 (Final)
Webmin version 1.831
Virtualmin version 5.07
Linux 2.6.32-642.el6.x86_64 on x86_64

/var/log/proftpd is empty
/var/log/messages has nothing related to proftpd

netstat -an | grep :21
Gives me:
tcp 0 0 :::21 :::* LISTEN

/etc/init.d/proftpd restart
Gives me:
Shutting down proftpd: [ OK ]
Starting proftpd: [FAILED]

Restarting the service within Webmin:
Starting proftpd: [FAILED]

proftpd --configtest
Gives me:
Checking syntax of configuration file
Syntax check complete.

Gives me nothing.

Attempting to apply changes (without actually making any changes) in the Webmin ProFTPD server module results in this message:
Failed to apply FTP configuration :
Checking syntax of configuration file

  • Fatal: SFTPHostKey: unable to check ‘/etc/ssh/ssh_host_rsa_key’: Permission denied on line 287 of ‘/etc/proftpd.conf’

Note: the rsa key file and the dsa key file both exist in the location indicated on lines 287/8, though I don’t know how to ensure they are the correct keys.

service --status-all
Gives me:
proftpd (pid 28561) is running…

I’m lost!

What to try next?!?

Thanking the forum in advance.

Yeah this could be well know bug with Virtualmin and Centos 6 & 7, and if it is i dont know why Vmin devs are waiting for so long to fix it.

First do this and then Let me know if my suggestions helped.

Forgot to mention, Centos 6 doesnt have SystemD and so no systemctl, to restart sshd use service sshd restart. Regardless on my second suggestion you can completely delete that part or comment out.

It was long time when i used Centos 6 so not sure what is included in proftpd config file, but if my suggestions doesnt help post the content here and someone can check. Just use forum code tags so it makes easier to read and will not be modified by the forum.

Thanks very much for this. It’s good to know that I’m not (just) going crazy. 8-|

I followed your directions,and at first things just went kaput. Then, when I replaced the edited files with my pre-edit backups, the sftp worked!

So some parts of this are a mystery to me; but I’m glad it’s working. Thanks again for your help.