ProFTPd won't start after fresh install

Good Day!

I have problem with my ProFTPd Server status which is not running after fresh install of virtualmin via and after post installation wizards completed.

I already installed virtualmin in debian 9 jessie before and no error like this happen.

Can anyone help me how to troubleshoot this issue of mine?

OS - Debian 10.3
Webmin version 1.942
Usermin version 1.791
Virtualmin version 6.09
ProFTPD version 1.36

Why opening another topic about the same thing?
Did you try what I suggested?

yeah i tried what you have suggested and it works…i just thought maybe i post this topic under Virtualmin category…

Could you help me again? i will post screenshot here…Could you take a look to it? Im not really familiar with this logs of proftpd

It seems like you integrated the load of the module mod_tls.c and mod_sftp.c twice. But thats just a guess.
The other message is just a warning, that the option NoCertRequest is deprecated (no longer supported) and will be ignored starting with the proftpd version higher than 1.3.6-rc2 (most likely including 1.3.6).
Meaning you can remove that option if you use that version.


should is omit TLSOption in proftpd.conf ?
My ProFTPd Server is up and running, my situation is im using filezilla to connect with my ProFTPd server behind NAT and im having error when connecting to my ProFTPd server while using filezilla ?

I need assistance to setup my ProFTPd server

  • what to edit in config file?
    *Select whether what is more secure to use ftp over tls or ftp over ssh or what you can suggest?
    *Im using Filezilla but there error in directory list . after connect to my ProFTPd server.

It doesnt matter if you use sftp or ftps. Both should be fine as long as you make sure to enable explicit TLS usage.

That option I told you about, will be ignored with that version anways. So its not really doing something.
For editing the config files:
virtualmin panel -> server -> proftpd server . There you can change the config files (via web).
Otherwise login with ssh and do the changes via command line.

I am sorry for the late reply.

What i am saying is can you provide me how to modify my config file of my proftpd server so that filezilla will work on it after connecting …

Im using Filezilla but there was an error in directory list . after connect to my ProFTPd server.

In order to do that, I need to know what exactly happens or what not.
Because just saying “… im having error when connecting to my …” isn’t explaining the error itself. :smiley:
So please, either a screenshot or a logfile.

Good day!!

This is the error i got when i tried to connect to my ProFTPd server in vmin using Filezilla.

Add this line TLSOptions NoSessionReuseRequired inside the tls config or place it directly inside the proftpd main config. Restart proftpd after that.
Plus make sure passive ports are open and enabled.


Thank you very much!! Filezilla works perfectly fine now without error.

By the way, I have another concern to discuss about Let’s Encrypt certificate request for my domain, should i open new topic or post it now?

Glad it solved it.
And yes, please.

I am working to redirect test website from http to https and requesting for lets encrypt certificate but i got an error for request certificate but before anything else i let know what i setup first …

  • Webmin tab select Webmin then Webmin Configuration then
  • SSL encryption under *Redirect non-SSL requests to SSL mode= set “Yes” then save setting.


  • Virtualmin tab > select my domain then Server Configuration then SSL certificate then select Let’s Encrypt

Domains associated with this server

then click "Request Certificate

got this error

Request Certificate
In domain

Requesting a certificate for,, from Let’s Encrypt …
… request failed : Web-based validation failed : Failed to request certificate :

Traceback (most recent call last): File “/usr/share/webmin/webmin/”, line 198, in main(sys.argv[1:]) File “/usr/share/webmin/webmin/”, line 194, in main signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, log=LOGGER,, disable_check=args.disable_check, directory_url=args.directory_url, File “/usr/share/webmin/webmin/”, line 143, in get_crt raise ValueError(“Wrote file to {0}, but couldn’t download {1}: {2}”.format(wellknown_path, wellknown_url, e)) ValueError: Wrote file to /home/domain/public_html/.well-known/acme-challenge/V3GsL5uZeHCx1Gt81x_mBpHtJ6MuKnSkngwoo215qvU, but couldn’t download

  1. Is there a way to download Let’s Encrypt via https than http for
  2. Is there anything i forgot to edit in config file?

if mail feature was not enabled i can request Let’s Encrypt certificate and my domain could automatically redirect to https and my ssl is good with the grey lock icon

You should have requested a certificate before doing other changes, but I am not sure if that would really change the outcome in your case.
The easiest way is to exclude the .well-known directory from the redirects.
That code should be placed directly into the vhost or via .htaccess.

A new topic would have been better to make it more clear whats what (my previous answer wasnt clear because I read the question only partially).

Thank you very much for putting so much attention in my issue… It was a big help for me… I will open new topic for this for others to see with similar cases like mine

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.