ProFTPD installation issues

Hello, I recently installed Webmin + Virtualmin on my VPS.

I’m trying to install ProFTPD to manage FTP access;

At the end of the installation, I received a success message, saying that the file is installed in:

/ usr / libexec / webmin / proftpd

But when I try to start the service, it tells me that was not found any installation in:

/ usr / sbin / proftpd

I tried to configure the module with this new path: (/ usr / libexec / webmin / proftpd).

But when I try to restart the service, it tells me that was not found the file proftpd.conf

What can be the problem?


How did you go about installing Virtualmin?

Normally, a Virtualmin installation includes ProFTPd, when using the automated script.

Also, distro/version are you using?

And what VPS software is your provider using (is it by chance OpenVZ)?


I’ve installed Virtualmin with the "Virtualmin module in RPM format "

Operating system CentOS Linux 5.9
Webmin version 1.620
Virtualmin version 3.99.gpl GPL

Yes It’s OpenVZ


If you installed Virtualmin via the RPM, that means you’re performing a manual installation… and that you’d need to manually install all the dependencies you wish to use.

There’s documentation here on performing a manual install:

In your case, it sounds like you may have installed the ProFTPd Webmin module, and not actually the CentOS package that provides ProFTPd.

However, if at all possible – we highly recommend using the automated script to perform an installation, and doing so on a fresh install of your distro. Doing that will save you a lot of setup work :slight_smile:


So it’s better for me re-install with ?

How i can uninstall this installation and use a ?


Yeah, we always recommend the script, at it performs all the setup work for you, which saves quite a bit of time.

However, that only works if you’re working with a new installation of your distro – or you haven’t done any setup work, such as trying to setup websites and email addresses.

You can use “rpm -e” to remove an RPM… but if possible, we’d instead suggest reinstalling your distro, and then using the Virtualmin installer (available in the Downloads section above).


I’ve try the mode, but the final message is:

Your system has 2 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
Mail server Postfix is installed and configured.
Your Postfix version does not support per-domain outgoing IP addresses.
Apache is installed.
The following PHP versions are available : 5.1.6 (/usr/bin/php-cgi)
Webalizer is installed.
Apache is configured to host SSL websites.
MySQL is installed and running.
The ProFTPd server does not appear to be installed on your system, or has not yet been set up properly in Webmin's ProFTPd Server module. If your system does not use ProFTPd, it should be disabled in Virtualmin's module configuration page.
.. your system is not ready for use by Virtualmin.

Any suggestions?

And this is the reply if I do: yum install proftpd

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base:
 * extras:
 * updates:
Setting up Install Process
Package proftpd-1.3.3g-2.el5.i386 already installed and latest version
Nothing to do

And when i try to start:

The program /usr/libexec/webmin/proftpd does not appear to be the ProFTPD server. Maybe it is not installed, or your module configuration is incorrect.

Hmm, did you format and start over, or are you installing Virtualmin onto your existing system?

It sounds like you may have made some changes trying to get ProFTPd to work previously – and those changes are currently making it so that Virtualmin isn’t detecting ProFTPd :slight_smile:

The ProFTPd daemon isn’t located in “/usr/libexec/webmin/proftpd”, that’s just a Webmin module.

The ProFTPd service is located in “/usr/sbin/proftpd”.

You may need to put the path back to /usr/sbin/proftpd in order to get Virtualmin to see it properly.


ok problem solved :wink: thank’s