Proftpd help

HI Guys

i am tottally new to unix and after some research i managed to set up a centOS 5 box ran the yum update then installed virtualmin via the setup script and all installed fine with the exception of the clamAV not being able to update warning message.

my aim is just to have a home server where i can learn unix/linux and also have permant site and ftp and cvs access for when i’am out and about.

ftp seems ok but it wont allow me to navigate out of the home dir so i tried in the ftp virtual server setting to add in the limit users section under where it says home dir and group of !adm a new section with the path of /var/www/html and group of everyone for now but this dosnt work and always loggs into the homedir could some kind sole give me a run down of what i need to do here do allow this to work i have set up a new user called ftpadmin and would like to have access to the whole /var/www section of the server if possible


you can log in as root under sftp or better yet create a new user and manage what he can do under webmin users. Give that user /bin/sh under webmin-system-users and groups

also you can create a webmin group and select privileges per module, then add that user to that group.

normally one would:
create a server template with selected privileges and make a virtual server like that.
The domain would then be found under /home which is the default setup instead of using /var/www/html, in case you want to add for instance subservers or just more domains etc.


The other thing you might do is after logging into Virtualmin, click the “Limits and Validation” link on the left. There’s an “FTP Directory Restrictions” section where you can set what directories FTP users have access to (or even have special permissions for particular virtual servers).



Thanks that did the trick i created a user ftpadmin and gave him /bin/sh then with my ftp client used sftp/ssh and i can log in and have access to my whole server :slight_smile:


Thanks for the reply i tried this but i think i did something wrong here or it didnt take effect as i ticked the activate box and ticked the All files on system or placing a path in the Other directory section but it would’nt allow me to navigate out of the home dir i would like to solve this issue as i would like to allow some people to ftp into my server but only allow them to a certain directory ie /var/www/html

thanks for all the help so far guys

i think the best way is to create a virtual server through virtualmin.
as you create only one then the /var/www/html is "replaced"/substituted by the /home/ which is more to the standard behaviour of webmin/vm and will make it easier for you to manage

you can then create ftpusers in that domain and give them appropriate rights.