proftpd filezilla directory listing issue

I am having issues after a fresh install of virtualmin, I cannot get my client FTP to connect to the proftpd server. The error message is below.

Please note I did research before posting this, I tried the recommended fix of running on “modprobe ip_conntrack_ftp” as root virtualmins FAQ.

I tried I restarting firewall, shut it down, started it up, rebooting the system, and still no luck.

This is the error from my client.

Status: Resolving address of ***
Status: Connecting to :21…
Status: Connection established, waiting for welcome message…
Status: Initializing TLS…
Status: Verifying certificate…
Status: TLS connection established.
Status: Logged in
Status: Retrieving directory listing…
Command: PWD
Response: 257 “/” is the current directory
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (
Command: MLSD
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

I am seeing no errors logged by proftpd server


Take a peek at this, and see if this helps: