ProFTPD authentication

ProFTPD will not let me login! Pleas help. I have the correct user/pass but it still won’t let me login.


Well, what errors show up in the error log?

However, also check out the tail end of this thread, where someone resolved a similar problem just today:

I have nothing in /var/log/proftpd

Can someone please help me with this?

Did you look in the link I offered above? :slight_smile:

Someone just had the problem you described – try the solution in the post at the above link and let us know if that helps.


Yes, and I looked at my /var/log/messages and I see nothing about the auth

Not the part about the logfiles – I gave a link to another forum thread above, where someone had the same problem as you’re seeing.

You can see their resolution in this bug request:


I have already checked those links and they didn’t help me. I already have pam commented out.


Still need help with this. :frowning:

Okay, a few additional questions:

  1. What distro/version are you using?

  2. What ProFTPd version are you using?

  3. Can you attach a copy of your /etc/proftpd/proftpd.conf file?

  4. What shell is the user in question using?



Here you go sir,

CentOS release 5.3 (Final)

ProFTPD Version 1.3.2


The txt file provided is my config



Okay, first off, a silly question, but I have to ask :slight_smile:

Did you restart the ProFTP server after commenting out the pam line in the config?

Also, as you attempt to log in, CentOS should log some info into /var/log/secure – do you see any messages relating to FTP?

However, you also seem to be using a version more recent than what’s provided in the Virtualmin repo.

While it of course should work, some folks have reported problems with some versions of ProFTP, and it’s possible that there’s an issue with the version you’re using.

Does it work if you use the version provided in the Virtualmin software repository?


Yes, I did restart the service.

Aug 27 11:53:41 server proftpd[30885]: localhost.localcomain (::ffff:[::ffff:]) - USER anonymous: no such user found from ::ffff: [::ffff:] to ::ffff:
Aug 27 11:53:41 server proftpd[30885]: localhost.localcomain (::ffff:[::ffff:]) - FTP session closed.
Aug 27 11:53:50 server proftpd[30890]: localhost.localcomain (::ffff:[::ffff:]) - USER brandon.myxtalk (Login failed): Incorrect password.
Aug 27 11:53:50 server proftpd[30890]: localhost.localcomain (::ffff:[::ffff:]) - FTP session closed.

Thats the only version of Proftpd that I have.

What do you get if you type:

rpm -qa | grep -i proftp




That appears to be the ProFTP version provided in the DAG repository.

What happens if you switch to the one provided by Virtualmin?

You can download it here:

And then as root, run the following to install it:

rpm -Uvh --oldpackage proftpd-1.3.0a-3.el4.i386.rpm

Note that the config provided in the Virtualmin package may not get used by default, since it likely won’t overwrite your current config. If things don’t work out of the box, you may want to replace your current config with the one you get in the Virtualmin-provided proftp.


Where would I find the virtualmin proftpd config at?

While running rpm with the above mentioned parameters, it would tell you what it does with the config file. It might name it something like proftpd.conf.rpmnew, for example.


K - I tried everything I could read about this and finally found a solution. So, I hope this works for all of you who are having the same issue.

I added the following line to the /etc/proftpd.conf file:


I’m using CentOS 5.5 and the current Virtualmin… 3.83.gpl GPL
Webmin: 1.530
ProFTPd version 1.32

It was found in the following article:

Thank you Ryan… you were a big help.

My proftpd works without these settings (centos 5.5). I think there could be something wrong with your installation. Your proftpd version should be actually: ProFTPD Version 1.3.3c (which also fixes a security issue in 1.32)