Procmail error after 3.64

I am not sure that the problem come with the 3.64 Virtualmin.
But I get this error on Re-check Config after the upgrade:
The procmail command procmail has 0 permissions, when it should be setuid and setgid to root. Email may not be properly delivered or checked for spam.

After some search on the Net, I find that I need procmail-wrapper.
But I’m not able to find it for Debian x64 (My server is on Ubuntu 8.10 x64).

Some help please.

What I did during the install:
sudo apt-get install apache2 wget perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl libmd5-perl cron mysql-server proftpd postfix webalizer logrotate spamassassin procmail dovecot-common dovecot-imapd dovecot-pop3d
sudo dpkg -i webmin_1*.deb
sudo dpkg -i usermin_1*.deb
sudo dpkg -i webmin-virtual-server*.deb
sudo dpkg -i webmin-virtual-server-theme*.deb
sudo chown root /usr/bin/procmail
sudo chown root.root /usr/bin/procmail
sudo chmod u+s /usr/bin/procmail
sudo chmod g+s /usr/bin/procmail
sudo nano /etc/postfix/ and add:
mailbox_command = /usr/bin/procmail
virtual_alias_maps = hash:/etc/postfix/virtual
sudo groupadd ftp
sudo nano /etc/shells (add /bin/false)
sudo apt-get install quota
sudo nano /etc/fstab (add ,usrquota,grpquota to the partition with the mount point / )
sudo touch /quota.user /
sudo chmod 600 /quota.*
sudo mount -o remount /
sudo quotacheck -avugm
sudo quotaon -avug
sudo nano /etc/apt/sources.list (add deb sarge contrib)
sudo nano /etc/apt/sources.list (add deb virtualmin-hardy main)
sudo apt-key add RPM-GPG-KEY-virtualmin
sudo apt-key add RPM-GPG-KEY-webmin
sudo apt-get update
sudo apt-get upgrade
Login to the webmin panel with the syntax:
Enable the Virtualmin theme. Select Webmin at the top left, Webmin, Webmin Configuration, Webmin Themes. In the dropdown box, select Virtualmin Framed Theme and click Change.
Enable apache modules. From webmin, click the Server drop down, then Apache Webserver. Select Global configuration tab, Configure Apache Modules, make sure actions, rewrite, ssl, vhost_alias, and any other modules you require are enabled.
Disable suexec in Apache. From virtualmin, click System Settings drop down, Server Templates, Default Settings. In the edit template section at the top, choose Apache website. Where it says "Automatically add appropriate SuExec directive?" select no then save.
Setup MySQL Login. From webmin, click the Server drop down, then MySQL Database Server. Put the Login and Password.
Enable Features & Plugins of virtualmin. From virtualmin. click the System Settings drop down, then Features and Plugins. enable SSL Website, ProFTPd server, Spam filtering and Virus Filtering.
Re-check the virtualmin config. From virtualmin, click System Settings drop down, and Re-Check Config. It should validate if the above steps were followed.<br><br>Post edited by: manus, at: 2008/12/19 04:33

I’m impressed, that’s quite a series of steps there!

For future reference, the script does all that for you though (and a few other things, which I’ll get to in a moment :slight_smile: You can find that here:

In your case, it looks like you’re missing the procmail-wrapper package.

You can install that with:

apt-get install procmail-wrapper

Out of curiosity, did you find the above steps somewhere, or did you tinker around until that all worked? If you found them somewhere, we may want to suggest the author modify them to make use of the much simpler! :wink:

The step are a mixing of some tutorial.
I can’t use the script on Ubuntu x64 8.10, If I can now it’s a good news.

I get the same error with procmail-wrapper installed :frowning: and the postfix changed:
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
to replace:
mailbox_command = /usr/bin/procmail

I have a virtual server with the same install and it’s work, I don’t understand why just with this server.

Issue resolved, I forget to remove the default mailbox_command :
mailbox_command = /usr/bin/procmail -a "$EXTENSION"