problems with virtualmin debian lenny packages

I upgraded recently to debian lenny and now I have problems trying to use the new virtualmin lenny repositories as described here : virtualmin-lenny main virtualmin-universal-lenny main

I run virtualmin pro on a couple of servers for 2 years. For the record I initially installed virtualmin 2 years ago manually, not from the script, and I use the virtualmin repositories for the updates. I wish I knew back then because there were several problems I have encountered and solved manually.

Here are some problems I get

In debian lenny apache version is 2.2.9-10+lenny4.

This was installed over apache2_2.2.3-50 which was on virtualmin etch repository.
If I am not mistaken I have to use a custom apache package to use features like protected web directories

Now when I try to enable them through virtualmin I get the following error

Failed to save enabled features : The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin base directory is /home. CGI and PHP scripts run as domain owners will not be executed.

Is there a custom package in the virtualmin lenny repository yet, or should I wait?

When I try to upgrade virtualmin with the command

apt-get install virtualmin-base

I get the following situation which tries to uninstall courier-imap and courier-pop

The following packages are BROKEN: courier-imap courier-pop virtualmin-base The following NEW packages will be installed: apache2-doc{a} clamav-docs{a} clamav-freshclam{a} clamav-testfiles{a} dovecot-common{a} dovecot-imapd{a} dovecot-pop3d{a} irb{a} irb1.8{a} libapache2-mod-fcgid{a} libpg-perl{a} libreadline-ruby1.8{a} libruby1.8{a} mailman{a} php5-cgi{a} procmail-wrapper{a} pwgen{a} rdoc{a} rdoc1.8{a} ri{a} ri1.8{a} ruby{a} ruby1.8{a} scponly{a} spamc{a} subversion{a} 0 packages upgraded, 27 newly installed, 0 to remove and 0 not upgraded. Need to get 27.2MB of archives. After unpacking 113MB will be used. The following packages have unmet dependencies: courier-imap: Conflicts: imap-server which is a virtual package. courier-pop: Conflicts: pop3-server which is a virtual package. virtualmin-base: Depends: webmin-security-updates which is a virtual package. The following actions will resolve these dependencies:

Remove the following packages:

Keep the following packages at their current version:
virtualmin-base [Not Installed]

Score is -9599

Accept this solution? [Y/n/q/?]

As for the package not installed but needed: webmin-security-updates that’s another issue. When I try to install it back from the virtualmin etch repository, i get a message it is already installed and it fails. And I dont know how to solve this either

I would appreciate any help with the above issues. Thanks!


For your first problem, it looks like you may have overlooked Step 5 in the Lenny Upgrade HOWTO you had used, which offers:

5. This will probably (hopefully) install apache2-suexec-custom. Configure it in /etc/apache2/suexec/www-data to point to /home instead of /var/www (this is the first line in the file).

That should just be a matter of tweaking that config file.

For the second problem – that’s interesting :slight_smile:

I’m not quite sure what to make of that.

However, I think I’d be tempted to allow it to remove the 4 packages that it mentions, as I don’t believe there’s any need for courier (Dovecot is the IMAP/POP server being used by Virtualmin).

So I’d give that a shot, and then we can move forward from there :slight_smile:


Hi Eric,

You are right. I have overlooked the /etc/apache2/suexec/www-data mainly because I thought, the directory had to be specified in compilation time of apache and so use a precompiled custom apache package.

So the suxec was solved! Thanks!

To make it clear I have a question:

In the virtualmin pro lenny repositories there are no custom apache packages like they are in the virtualmin etch repositories. Is this because they are not needed now for virtualmin setup. Is the official debian lenny apache packages satisfactory for all virtualmin features?

As for dovecot, I didn’t know that it is the one supported by virtualmin. I will probably switch to it. This will take time since now courier is configured for 15 domains, with standard, ssl and tls support . I will need to do some search to setup dovecot, but I will do it eventually. Thanks for pointing this out!

The only problem with the upgrade that would remain, is package webmin-security-updates. The deb package is not installed, however when i try to install it I get an error

This Webmin module is already installed on your system.

Could it been installed by webmin module installer, or by another way? I went to webmin modules and searched for it but I couldn’t find anything to remove. I didn’t know how to manually remove it by editing webmin config files and deleting files. Any suggestions on that?



Correct, there are no customer Apache packages for Lenny – Lenny’s Apache package will work just fine.

As far as the security updates package is concerned – I’m not sure there. I suppose it could have been installed another way in the past.

What do you get if you type this:

dpkg -l ‘webmin’ | grep security

Does that show anything?


No dpkg -l ‘webmin’ | grep security does not show anything.

This is the result from dpkg -l ‘webmin’
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
ii webmin 1.480 A web-based administration interface for Unix systems

Is there a manual way to remove the indication of an installed webmin module, lets say from a config file where all installed webmin modules are?

My last resort would be to extract the .deb package webmin-security-updates, check the code in the script that installs and hope that it will direct me to a config file I can remove some lines to trick it. But that’s too much and I would like to know if there are easier solutions.

Should I make a new post just for that? For example titled : Ways to remove modules installed outside apt or yum mechanism. I have seen this error again for other modules in the past. Previously I have managed to solve it by uninstalling through webmin. Now I can’t find it there and I need other suggestions.