Problems with mail, SPF authentication

I have domain pointing to VPS, where virtualmin is installed. The email worked perfectly, but it has stopped working, when I send to gmail emails. It sends me the error:

Diagnostic-Code: smtp; 550-5.7.26 This message does not pass authentication
checks (SPF and DKIM both 550-5.7.26 do not pass). SPF check for
[] does not pass with 550-5.7.26 ip: [].To
best protect our users from spam, the message 550-5.7.26 has been blocked.

I’m new to this and I have some questions. DNS records for mail I just have to configure in virtualmin?
I have options in:
Domain web DNS records.
VPS DNS Records.
DNS records virtualmin.
I don’t know if I have to configure each of these options or on the contrary everything is managed by virtualmin?

OS type and version CentOS Linux release 7.9.2009
Virtualmin version Versión 7.1

Spf and dkim are common issues. Did you Google it the codes? If so correct your issues in records, give it at least 24 hours and test it again. See output and take it from there.

I am not arrogant here, just you need to learn what you dealing with it. It would be no issue for you… for next time you know.

1 Like

Use SPF Check & SPF Lookup - Sender Policy Framework (SPF) - MxToolBox to test.
Here is a tool to create the rule
Generator - SPF-Record

1 Like

I am making the changes, but I don’t know exactly where I have to enter the SPF record. I do it in virtualmin in DNS records.
I have domain Hostalia(here there are DNS records), VPS contabo(here there are DNS records) and virtualmin(with its DNS records). I think my problem is that I don’t know which of the three to put the SPF record into.
I always make the changes in virtualmin.
Any ideas. Thanks.

Since it is Virtualmin that is doing all the work of hosting email and web, it is Virtualmin’s DNS which should be considered as master / primary.

Copy whatever you find in Virtualmin DNS over to the other DNS services.


Can you check your IP on spam house or any other online crapware? If found, make sure you unlisted after changes you would made

1 Like

Thank you. This solved my problem.

Copy whatever you find in VirtualminNS over to the other DNS services.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.