Problem with Wordpress migration


I was able to setup virtualmin, swap… so basicly the system is running fine, I have disabled mail and spam services so that I have enough memory on my 512MB VPS.

I was able to move Mysql db and files to my vps. Blog seems to work, With the help of this forum I was able to fix permissions after zip extraction.

I have only one problem now, pictures are not showing up. after googling the only thing that looks to be the problem is mod_rewrite not working.

I checked webmin - servers - apache webserver - global configuration - configure apache modules - rewrite is enabled.

I also found one post to enable mod_rewrite: edit /sites-enabled/000-default and set AllowOverride to All.

Problem is that site is still not showing pictures (i reenabled permalinks).
Are there any other settings for mod_rewrite?

Regarding site transfer, its very simple, domain is the same so it should not be a problem.
From cpanel to cpanel hosting transfer there was never a problem.


Normally, mod_rewrite works out of the box, there shouldn’t be anything you need to do in order for that to work.

If you run this command, it should show “rewrite.load” in the modules.enabled directory:

ls -l /etc/apache2/mods-enabled/rewrite.load

Is there some sort of error you’re seeing in the error logs though?

The error logs for that domain would be located in $HOME/logs/error_log.


Hi Eric,

Good, it seems mod_rewrite works.
lrwxrwxrwx 1 root root 40 Sep 18 20:07 /etc/apache2/mods-enabled/rewrite.load -> /etc/apache2/mods-available/rewrite.load

No, in logs there is nothing that could point to the problem.
There are some errors for 22th September, that files don’t exist, but, I think I fixed that as I don’t have any errors since then.
I checked accessed log and there are records for today.

I wish I knew what else I could do.


Hi Eric,

I was able to get response from theme developer.
They told I need to install GD library.
Once I installed, theme works like it should

Thanks for help!

Great, I’m glad you got that working!