Problem with multiple destinations backup


The sever makes a scheduled double-destination full backup of multiple servers and virtualmin settings, one file per server. One destination is local file the other one is ftp.

All worked fine untill I upgraded from 3.94-2gpl to 3.96gpl. Now, when the backup is run (scheduled or through Virtualmin UI), it succeds on the ftp destination but fails in the local file system.

In the local file system destination, the backup process only leaves the virtualmin.tar.gz and files. Refreshing the destination directory during the backup process, It seems that the individual files for each server are created but deleted one after the other. No one remains once the process ends.

I have tried to change the order of destinations declaration in the backup form (local file first or ftp first) with no visible result (ftp is always ok, local file is never ok).

On this system, single destination backup works fine on both local file system an ftp (using the very same destinations that are used in double-destination).

Reading the 3.95 changelog, I see that some modification have been made to improve the backup functionality. But it seem that something was broken in multiple destinations backup…

There may be a bug in Virtualmin 3.95 regarding that, someone else was reporting a similar issue.

Could you post your request as a bug report, using the Support link above? Jamie will then be able to work with you to get that sorted out.



My configuration is similar, backup in 2 destination, a NAS mounted as folder (dest 1) with multiple backups, and FTP (alternative dest 2) for keeping only one day backup. The backup was working for years, few days ago I made a scary discovery, NAS backups were empty. The backup report was indicating success.

It’s really urgent BUG to fix. I am sure many people count on these backups, I just hope the problem will be fixed ASAP, before some one needs them and discover they are useless.

PS. Can’t browse the BUG reports without log-in. Search results are always empty and nothing is indicating a problem or need to log-in

Dear Sir:

I meet this problem, too. awaiting the solution. :slight_smile:

Posted a bug report: