Problem with installation on Centos7 - Certificate cannot verified

OS type and version: Centos7
Webmin version: /
**Virtualmin version:**Newest
Related products version:/

Hello all,

im quiet new with Servers, Centos, Virtualmin und SSH in general.

I managed to setup my server and install Homebrew etc.

Now when i want to run the installation I get following error message in the Terminal of my MacBook,:

ERROR: cannot verify's certificate, issued by '/C=US/O=Let\'s Encrypt/CN=R3':
  Issued certificate has expired.
To connect to insecurely, use `--no-check-certificate'.
chmod: cannot access '': No such file or directory
./ line 297: ./ No such file or directory

I checked the error in Google already but the solution either didn’t work or i dont understand them correctly I guess.

Has this something to do with my dedicated server or is this a issue on your site?

I downloaded Virtualmin and installed it via the command sudo /bin/sh But soon as i run the command i get the Certificate error and also /

Can anybody help me out here?


That’s an odd error, I assume you are using the script from:

*** Might I make an observation regarding your OS choice. CentOS 7 is no longer receiving “full updates” and only receiving “maintenance updates” at this time.

It is recommended that you install a more recent version, either CentOS 8 Stream, Rocky Linux, or another RedHat based distro (based on your usage of CentOS). ***

Though, I’m wondering if perhaps there was a technical hiccup on the Virtualmin server, have you retried the install since the error?

Update your system. You have the old CA certificates bundle.

Neither CentOS Stream nor Rocky are supported by the Virtualmin installer yet (they will be in the Virtualmin 7 installer).

The supported Operating Systems are listed on our OS support page. If you prefer CentOS, we recommend CentOS 8.

But, there is literally no reason to install CentOS 7 for a new deployment today. CentOS 8 is the current and recommended release of CentOS. (But, CentOS 7 will work, as long as it is updated.)

Strongly recommend to use CentOS 8 and not 7 if this is a new server. I use 8 and cant see any good reason to use 7 and old packages. Personal preference must be noted as others will say Ubuntu, Debian etc. If you are able, run a virtual container on your mac/pc and test different distributions to see what your preference would be.

1 Like


i updates to Centos8 and it worked!

Thanks for the help.

Issue resolved.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.