Problem with Amazon EC2 server

I install Virtualmin in a Amazon EC2 server following http://www.virtualmin.com/documentation/aws/virtualmin_gpl_ami/

I create the virtual server ‘example’, but i can not see the folder ‘/home/example’, ‘/home/bind’, and ‘/home/apache2’

What can I do? Thanks!

Howdy,

Hmm, can you provide more details on the problem you’re having?

Are you receiving errors of any sort?

-Eric

I connected to EC2 server using command line: $ ssh -i {directory}/{key}.pem ec2-user@ec2-{something}.compute.amazonaws.com

I installed Virtualmin following steps explained in: http://www.virtualmin.com/documentation/aws/virtualmin_gpl_ami/

I create the virtualserver ‘example’ from Virtualmin

But, when I want to crate a ‘index.php’ in ‘/home/example/public_html’, i can’t see the folder ‘/home/example’

Apache and Bind, both are running. But i can not see directories ‘/etc/apache2’ and ‘/etc/bind9’

Do you understand me?

Virtualmin installation need restart the server?

Ah, it sounds like you’re saying that after using Virtualmin to setup a Virtual Server for you – that the directory for that particular account is missing.

What folders do you see when you look in /home/?

Also, if you look in Virtualmin, do you see your domain listed in Virtualmin, in the drop-down box on the top-left?

What Linux distribution/version are you using?

-ERic

Thanks for your reply :slight_smile:

Exactly.

I only see folder ‘/home/ec2-user/’

Yes, I can see my domain in this select

The operating system is Amazon Linux 2012

Nothing?

Hrm, I’m honestly not really sure… what you’re describing there sounds like something is very awry.

What happens if you create a new top-level domain – does it create the /home/USER directory for that particular user?

Also, what is the output of this command:

rpm -qa | grep httpd

Thanks for your reply.

The command ‘rpm -qa | grep httpd’ has no output:

[ec2-user@hostname ~]$ rpm -qa | grep httpd
[ec2-user@hostname ~]$

If I create a new top-level domain I can’t access to /home/{user} directory. But when Virtualmin is creating the virtualserver I see that there isn’t any problem: “Creating home directory … done”

Creating administration group test …
… done

Creating administration user test …
… done

Creating aliases for administration user …
… done

Adding administration user to groups …
… done

Creating home directory …
… done

Creating mailbox for administration user …
… done

Adding new DNS zone …
… done

Adding to email domains list …
… done

Adding default mail aliases …
… done

Adding new virtual website …
… done

Adding webserver user apache to server’s group …
… done

Performing other Apache configuration …
… done

Setting up scheduled Webalizer reporting …
… done

Setting up log file rotation …
… done

Creating MySQL login …
… done

Creating MySQL database dbtest …
… done

Setting up spam filtering …
… done

Setting up virus filtering …
… done

Setting up AWstats reporting …
… done

Setting up password protection for AWstats …
… done

Adding DAV directives to website configuration …
… done

Adding DAV account for server administrator …
… done

Creating Webmin user …
… done

Re-starting DNS server …
… done

Applying web server configuration …
… done

Re-loading Webmin …
… done

Saving server details …
… done

Howdy,

Hmm, it sounds like something somewhere along the way went terribly wrong.

You’re not seeing any directories for the account’s it is creating, and it also doesn’t appear that your server has Apache installed.

So, it doesn’t sound like things are functional right now.

Is there any chance you could attach the virtualmin-install.log file that’s generated during the installation process? Perhaps that will contain some clues as to where things went awry.

-Eric

I think that I have not sufficient permission when I login by SSH using PEM key, because from Virtualmin I can see directory /home/{virtualmin_user}

I can’t login with SSH in step 8 (http://www.virtualmin.com/documentation/aws/virtualmin_gpl_ami/)

[ec2-user@{hostname} ~]$ ssh -i ~/.ssh/id_rsa-vgpl-keypair root@ec2-{something}.compute.amazonaws.com
The authenticity of host ‘ec2-{something}.compute.amazonaws.com ({ip})’ can’t be established.
RSA key fingerprint is {fingerprint}.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘ec2-{something}.compute.amazonaws.com’ (RSA) to the list of known hosts.
Enter passphrase for key ‘/home/ec2-user/.ssh/id_rsa-vgpl-keypair’:

What have I to put here?

You need to replace ec2-{something}.compute.amazonaws.com with your server’s IP. You’re trying to SSH into the root account of a machine that (most likely) doesn’t exist.

Due to complications, I decided to install LAMP. Thank you very much anyway!