Problem to send gemail email

Operating system CentOS Linux 7.8.2003
|Webmin version|1.981|
Usermin version**|1.823|
Virtualmin version**|6.17|

I have been receiving the following response to any email I send to any Google mail account which originates from my virtualmin server.

host aspmx.l.google.com[2a00:1450:400c:c06::1b]
said: 550-5.7.1 [2a01:4f8:161:43aa::2] Our system has detected that this
message does 550-5.7.1 not meet IPv6 sending guidelines regarding PTR
records and 550-5.7.1 authentication. Please review 550-5.7.1
Prevent mail to Gmail users from being blocked or sent to spam - Gmail Help for more information 550
5.7.1 . t15-20020a05600c198f00b00389e765b531si1558728wmq.19 - gsmtp (in
reply to end of DATA command)

when i send email to another email account not google its working i have problem only with gmail account

help me to fix it

The error message is pretty obvious: you should look into the PTR records of your domain name, especially those concerning the IPv6.

Don’t forget https://intodns.com, it will give you a clear view of what is going wrong.

You might also fix the problem the lazy way by asking Postfix to use only the IPv4. Something like:

inet_protocols = ipv4
1 Like


in server configuration -dns record i dont have IPv6 configured

check picture attached

this is my dns server: bios-downloads.com

just check it in linnk above

for PTR i dont see any error message

Reverse MX A records (PTR) Your reverse (PTR) record:
169.51.9.5.in-addr.arpalnx-dedi01.bios-downloads.com
You have reverse (PTR) records for all your IPs, that is a good thing.

That’s not what the error message is saying. The error message;

Is saying that Google has accepted an inbound connection from your IPV6 adddress, and the in-addr for that IPV6 address doesn’t match what it’s looking for. You can either disable IPV6, or fix the IPV6 PTR record for 2a01:4f8:161:43aa::2

1 Like

can you exaplain me how to do it ?

i am not server specialist

I think the easiest way would probably be to go to webmin, networking, network configuration, then in the right hand window select your Ethernet interface, click on the radio button for “IPV6 Disabled” and restart networking/reboot the server. I’m sure others can provide a better/different way. I’ve not personally experienced anything in my environment that would be helped by using IPV6.

Your mileage may vary….

this is my configuration for my server Ethernet

Yeah, in the second screenshot I would make that say “IP6 Disabled” - but I’m not sure if there’s a dependency for IPV6 in your environment that does not exist in mine. It’s entirely possible, if not likely, that your virtual servers have also used an IPV6 address and won’t restart properly if you disable IPV6 here. It would take some close examination of your environment to see if disabling this is entirely safe.

The other two ways you can fix this would be what was suggested above; disable IPV6 in postfix with the flag (you’d have to edit the postfix config file by hand I think, I can’t find a way offhand in the UI), or see who has the PTR records for your IPV6 address and have them update it.

I’d like to point out a common misunderstanding regarding the PTR (reverse DNS) record: Whether it is IPv4 or IPv6, the PTR record is controlled by the entity controlling the IP.

You can simply ask the service provider from which you were assigned this IP to add the PTR record for you, if they don’t already offer some interface for you to do it yourself…

PTR has nothing to do with your domain or DNS settings. It is stored in a separate location, but if you want it to be useful for email, you should use a valid resolvable host name, such as mail.example.com.


i have that options configured in my server

When you click on the IPV6 address there what does it let you do? Does it let you put in the correct name?

There you need to put the ::2 address.

i add ip address and Reverse DNS entry
2a01:4f8:161:43aa:: lnx-dedi01.bios-downloads.com

also i add and AAA record

lnx-dedi01.bios-downloads.com
2a01:4f8:161:43aa::2

also i have IPv6 address configured in my server
Netmask
2a01:4f8:161:43aa::2

but still i have same problem

99% sure PTR records have to end in a .

If you edit your zonefile manually, sure, it needs a dot.
In Hetzners panel you do not :slight_smile:

@bios_fix - the records looks correct now.
If you’re still seeing errors when sending to Gmail please share the actual error as its unlikely the same.