PROBLEM SOLVED: Thunderbird client says: "TLS support isn't enabled", so can not send/receive on Virtualmin virtualhosts

Hello all

I have just migrated all Virtualmin virtualhosts to a new and fresh digital ocean droplet running Ubuntu 16.04 with latest Virtualmin/Webmin. (same ip-address as the old server)

Looks like everything is working well, exerpt connecting to those virtualservers with an external email client.

Using the same Thunderbird accounts and accountcredentials as used with the older Virtualmin/Webmin server running on Ubuntu 14.04, when I try to send or receive using Thunderbird, all I get is the following servermessage:

“TLS support isn’t enabled”

I tried deleting old certificates to grab new ones (if that could be the problem), but it did not help.

Do I need to enable TLS support, and if so …where and how do I do that?

Hope someone will be able to help me. Thank you.

PS: The server itself is continuing to send and receive emails as usual, but I can not send or receive using an email client.


BTW, I have the same connect problem on my mobilephone emailapp. “Can not connect to server”

I have also checked that all ports on the server are open. Configured UFW, but have even disabled it for testing, does not help.

Something must be seriously wrong. I tried connecting using SFTP and got answer “Disconnected: No supported authentication methods available (server sent: publickey)”

No supported authentication methods available…

I can connect using Putty/SSH console connection, and browse the virtualhostswebsites, but thats all it seems.

OK, the last one regarding SFTP connection problems was my own fault. In /etc/ssh/sshd_config I had put PasswordAuthentication no. Changed this to PasswordAuthentication yes and SFTP worked.

Still the same problem with email clients though…

Figured it out:

Wonder why this does not happen automatically when a virtualhost is created?