Problem in backup of mysql database

i set virtualmin to backup every virtual server in a file each night. Every backup runs smoothly besides one. Here i get the error:

mysqldump: Error 2020: Got packet bigger than ‘max_allowed_packet’ bytes when dumping table package_repository at row: 8

If i remove that row, the error will move a row up. When i remove row 9, which he claimed the error in, i removed that line and found out, that now it will throw the error on row 8…

I have several BLOB’s in that database, none of them larger than 32 MB and in summary they are perhaps 40 MB larges.

I googled around a bit and found out, i would have to change the parameter

max_allow_packet from 1 M to 1024 M, which i did, also i restarted MySQL.

But it won’t work. I also read, that mysqldump seems not to honor that setting in my.cnf.
So any idea what to do?
Thanks and best.

From what I’ve been reading (and a quick Google search) it appears the max_allowed_packets setting you updated doesn’t affect the mysqldump part.

From what I’m reading, it looks like if you add a new section to your my.cnf file called [mysqldump] and then put a max_allowed_packets = XXXM in it, that should solve the issue for you.


this did the trick :slight_smile: Didn’t knew, that i could create a mysqldump section in mysql.cnf.
Thanks again!