Problem changing domain name

Hi, I’ve been developing a new version of our website under Today I wanted to put it live so I did the following.

  1. Created a new subdomain
  2. renamed the domain -> (so we can still access the old site)
  3. renamed -> (so the new website is now on the main domain)

All the renaming was done using wirtualmin -> Server Configiuration -> Change Domain Name

Now when I go to it is still going to the old website (it actually redirects to which is very odd ).

What have I done wrong?


Not sure if there’s anything wrong as I have never done it that way. Unsure how virtmin handles the renaming but I would think going through all that was point less when you can just move files from the test folder to the public_html of the main domain. Renaming domains probably introduces dns updates which can take 2 days sometimes to propagate.

I’ve always created tests in subfolders of the main domain. for example. But subdomains would work also. Then once all is set, its just a matter of backing up original files in ‘/’ and then copy files from ‘/test’ to ‘/’ of the main domain. Or even simpler but not as pretty a url, is just making a redirect from ‘/’ to ‘/test’ folder. Sorry, no help on the way you tried, just the way that works for me.

I have the same a similar problem. When changing domain name, the email mapping still looks for the old domain, not the new one, and bounces incoming mail because the user (mail account) does not exist.

): unknown user: "user-olddomain.tld"

The rename domain function has worked fine before, but seems that something is broken now.