Pro advert tip on GPL System Info panel replaced by HASH(0x65f3cf0)

I am testing VirtualMin 7.1 after using 6.17 and older versions for several years.

I took an older test RedHat system with … 6.12 maybe?, updated it to 6.17 first, then updated it to 7.1 with

yum update wbm-virtual-server

and things went well. I also updated webmin to 1.994.

But now on the System Information panel, at the very top is displayed


when using the older Virtualmin Framed Theme. So I tried Authentic as I believe it is much newer. Now the error shows up when clicking on the small right hand floating Message/Notification – on that popup/flyout item, its towards the bottom in the Information! section – again displaying HASH(xxxx) instead of an actual message.

I played around a bit with Data::Dumper in /usr/libexec/webmin/virtual-server-theme/right.cgi to see what’s going on, but do not know how to fix it or where the real issue is.

I have a number of production RedHat servers and was hoping to do the 7.1 update in place … I have not yet tried installing 7.1 on a newly built system. My guess is something left over from my older configs could be the issue.

Here is what I see when using Authentic:

and here is my Framed Theme display with several debugging PRINT statements

Thoughts anyone?


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.