Postgresql won't enable in virtualmin

The post installation setup won’t let me set the databases to postgresql, nor will virtualmin let me enable the feature. It says:

Failed to save enabled feature : PostgreSQL does not appear to be installed and running on your system, or has not yet been set up properly…

I can’t set it up as it’s not installed, but it won’t let me install it.


Of course it’ll let you install it! It’s just a regular package from your OS vendor. Once installed, you can enable it in Virtualmin.

We removed pg from the default installation because so few people use it (I prefer it slightly, but there’s not much we can do to change the vastly larger preference for MySQL/Mariadb among the projects in the Install Scripts and in the web dev community in general).

Use your system package manager to install postgresql and postgresql-server packages (probably, you haven’t mentioned your distro and version, but I think that’s the right name on all distros we support). You can use the Webmin Software Packages module to do it or do it from the command line. You’ll also probably want the php pg driver packages, or the relevant drivers for the language(s) you’ll be developing with.

Once that’s done, you can use:

# virtualmin config-system PostgreSQL

To do some minor initial configuration (this may not be necessary, depending on your distro/version). Then you can either enable postgresql-server (systemctl enable postgresql-server) or re-run the Virtualmin post installation wizard to enable it.