Postfix/SMTP - Can't Connect (local and public)

Hello,

I have a fresh install of Virtualmin using the install script. I am running Ubuntu 20.04. Everything seems to be working except for Postfix/SMTP. I can receive mail, just can’t send it. I have confirmed the service is running, tried both secure and non-secure ports, even tried a custom port. I can’t even send a message via Usermin. I receive an error stating “ Failed to send mail: SMTP command failed”

I’ve searched the web high and low on how to fix this, but now i’m at a loss. Any help is appreciated!

Have you installed SSL on the domain, host, Postfix?..

Yes, I have a Let’s Encrypt cert installed.
Also, here is nmap from another host. I have removed my IP and Host:

nmap MYDOMAIN
Starting Nmap 7.80 ( https://nmap.org ) at 2021-07-15 19:43 UTC
Nmap scan report for MYDOMAIN (IP)
Host is up (0.00048s latency).
rDNS record for ----
Not shown: 988 closed ports
PORT STATE SERVICE
25/tcp open smtp
80/tcp open http
443/tcp open https
465/tcp open smtps
587/tcp open submission
993/tcp open imaps
6789/tcp open ibm-db2-admin
7443/tcp open oracleas-https
8080/tcp open http-proxy
8443/tcp open https-alt
8888/tcp open sun-answerbook
9090/tcp open zeus-admin

Nmap done: 1 IP address (1 host up) scanned in 0.21 seconds

On the domain you’re working on. Go to Server Configuration/SSL Certificate/Service Certificate and copy all certificates. Also do the same for your main server domain. That might work.

That’s one of the first things I did.

Oddly, I did look at them yesterday when I was trying to work through this and nothing was there that related to an error. Today, I see the following:

Jul 15 14:32:25 HOST postfix/smtpd[220468]: fatal: no SASL authentication mechanisms
Jul 15 14:32:26 HOST postfix/master[207801]: warning: process /usr/lib/postfix/sbin/smtpd pid 220468 exit status 1
Jul 15 14:32:26 HOST postfix/master[207801]: warning: /usr/lib/postfix/sbin/smtpd: bad command startup -- throttling

Issue fixed. I was stuck on it being a Postfix issue. It was actually a problem with Docecot config.