Postfix send problem - username @ or -

I had a server hack on saturday so transferred all sites (only 6) to another server.
all easily done with the backup and restore features of Virtualmin (have done quite often over the years)

However, sending emails failed to send.

I tracked this down to postfix failing to accept the send message request. saslauth was failing.

for some reason i stumbled across the solution.

I had to change the username from to

my question is this, why does the OUTGOING server username need to be instead of
did I make a mistake in teh backup.restore process ?

note that the incoming mail server settings still uses

both on GPL
new server:
CentOS Linux 7.7.1908
Webmin version 1.942
Usermin version 1.791
Virtualmin version 6.09

old server:
Operating system CentOS Linux 7.7.1908
Webmin version 1.942
Usermin version 1.791
Virtualmin version 6.09

thanks for any help.

This sounds like saslauthd doesn’t have the -r flag enabled, though I can’t think of why that would happen. Are you sure there were no errors during installation and that all steps completed?

Check this setting in /etc/sysconfig/saslauthd, and see if it has FLAGS="-r"

1 Like

Hi Joe,
many thanks for quick response.

no I am not sure if there were errors :see_no_evil:

here;s copy of that file.

# Directory in which to place saslauthd's listening socket, pid file, and so
# on.  This directory must already exist.

# Mechanism to use when checking passwords.  Run "saslauthd -v" to get a list
# of which mechanism your installation was compiled with the ablity to use.

# Additional flags to pass to saslauthd on the command line.  See saslauthd(8)
# for the list of accepted flags.

Looks fine.

You’ll need to check the maillog.

Also make sure you have users with @ in the names in /etc/passwd. There will be two usernames with the same UID (one with - one with @).

good shout !

I found that I had to change the passwd file, the email with - to above the @ and it now works as expected.
I then restarted saslauthd, and works, I’ll just get users to check.
thanks again for your help.

For your information, in relation worth checking would be:

  1. Virtualmin Configuration option
  2. Server Template option

I never noticed (or heard of) that option before
regards brian

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.