Postfix placing mails in queue and not delivering

OS type and version | Ubuntu Linux 20.04.6
Webmin version | 2.111
Virtualmin version | 7.10.0

Hello i have a freshly installed virtualmin but when i test email sending, its always being queued and not getting sent. I can confirm that port 25 is open, SMTP username and password were correct but cannot send mail. When i check mail logs i see the following errors:

1: fatal: specify a password table via the `smtp_sasl_password_maps’ configuration parameter
2: warning: process /usr/lib/postfix/sbin/smtp pid 4625 exit status 1
3: warning: /usr/lib/postfix/sbin/smtp: bad command startup – throttling
4: warning: unknown[IP Address]: SASL LOGIN authentication failed: authentication failure

Can some here kindly help get around this? I will great appreciate your response

Just to make sure we are starting off on the same page here.

We consider a freshly installed VM as being a fresh minimal OS install followed by running the VM script. I ask because Ubuntu 20 seems a strange choice to start with. I can understand maybe not wanting to jump to 24 yet, but 22 would be a better option to start from.

If the machine had a configuration and you just added VM to it then it isn’t a ‘fresh install’ in the way it is typically used here.

Have you tried the ‘check configuration’ option to see if it catches anything?

The warning usually aren’t show stoppers, but the ‘fatal’ would be but should have been set up on installation.

1 Like

Well, this is interesting. From 2015 no less.

After sone googling I found the solution which was typo (made by postfix or webmin) smtp_sasl_password_maps which should have been smtpd_sasl_password_maps hope it helps someone else.

1 Like

The error is caused by having smtp_sasl_auth_enable set to Yes, so set it to No. The virtualmin default is No or at least it was with my Ubuntu install.

Webmin --> Servers --> Postfix Mail Server --> SMTP Authentication And Encryption --> Use SASL SMTP authentication?: No

smtpd_sasl_auth_enable should be set to yes
Webmin --> Servers --> Postfix Mail Server --> SMTP Authentication And Encryption --> Require SASL SMTP authentication? Yes

1 Like

@shoulders thanks a million times! that was the fix! :wink:

thanks buddy!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.