Postfix not working after update

Debian: 9 (and 10)

I updated some packages from the virtualmin interface a few days ago and now PostFix does not seem to work.
I tried many things: rebooting, restarting postfix, upgrading debian from 9 to 10. But it still won’t start when I click the ‘start’ button on the virtualmin main page (under status).

I logged in using putty and did this:

service postfix status

● postfix.service - Postfix Mail Transport Agent
Loaded: loaded (/lib/systemd/system/postfix.service; disabled; vendor preset: enabled)
Active: active (exited) since Fri 2020-10-09 05:26:54 PDT; 6min ago
Process: 3059 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 3059 (code=exited, status=0/SUCCESS)

Oct 09 05:26:54 …: Starting Postfix Mail Transport Agent…
Oct 09 05:26:54 …: Started Postfix Mail Transport Agent.

postfix -v check

postfix: name_mask: all
postfix: inet_addr_local: configured 5 IPv4 addresses
postfix: inet_addr_local: configured 2 IPv6 addresses
postfix: Postfix is running with backwards-compatible default settings
postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
postfix: To disable backwards compatibility use “postconf compatibility_level=2” and “postfix reload”
postfix/postfix-script: warning: symlink leaves directory: /etc/postfix/./makedefs.out
postfix/postfix-script: warning: /var/spool/postfix/etc/ssl/certs/ca-certificates.crt and /etc/ssl/certs/ca-certificates.crt differ
postfix/postfix-script: warning: /var/spool/postfix/lib/i386-linux-gnu/libnss_systemd.so.2 and /lib/i386-linux-gnu/libnss_systemd.so.2 differ

I looked at the log and saw similar warnings as above:
Oct 9 05:35:00 …: name_mask: all
Oct 9 05:35:00 …: inet_addr_local: configured 5 IPv4 addresses
Oct 9 05:35:00 …: inet_addr_local: configured 2 IPv6 addresses
Oct 9 05:35:00 …: Postfix is running with backwards-compatible default settings
Oct 9 05:35:00 …: See http://www.postfix.org/COMPATIBILITY_README.html for details
Oct 9 05:35:00 …: To disable backwards compatibility use “postconf compatibility_level=2” and “postfix reload”
Oct 9 05:35:04 …: warning: symlink leaves directory: /etc/postfix/./makedefs.out
Oct 9 05:35:04 …: warning: /var/spool/postfix/etc/ssl/certs/ca-certificates.crt and /etc/ssl/certs/ca-certificates.crt differ
Oct 9 05:35:05 …: warning: /var/spool/postfix/lib/i386-linux-gnu/libnss_systemd.so.2 and /lib/i386-linux-gnu/libnss_systemd.so.2 differ

I looked at the postfix compatibility web page but I am not sure what options make it go in compatiblity. Also these are warnings so I am guessing this would not prevent postfix from running.

I also tried these but when I look at the postfix status, it is the same as above:
/etc/init.d/postfix start
service postfix restart

Your config files were probably overwritten during the upgrade. You may want to check them in /etc/postfix. The two most important files are main.cf and master.cf

Thanks for the suggestion.
It seems that both files were not modified since they are exact matches with my previous backup.
Anything else I could check?

I also tried this but got the same issue:
apt-get install --reinstall postfix
/etc/init.d/postfix start
/etc/init.d/postfix status

I would probably compare your current config files that I mentioned before with the ones from the new package. There probably is a setting in the new config files that you need hence the reason it’s going into backwards compatibility mode. You can usually find/view the new package files online.