Postfix mail not being delivered & no smtp login

I have ubuntu 8.04 server every works good on it, but when i try to send message to server it goes to the postfix server message queue and just sits there. The strange this is it does it with internal message also. I also have issue with login in to smtp server to send mail. I have no problem login in to pop.

when the messages are getting send to mail server it is looking for a domain that is not on the server. I can not find where it might be located at in any of the conf files…

here is the error for mail server for recieving mail:

Apr 29 08:18:31 XXXXXXXX postfix/smtp[11856]: E6A72114C175: to=<>, orig_to=<>, relay=none, delay=934, delays=933/0.01/1.7/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for type=MX: Host not found, try again)

I here is one for smtp login error:
Apr 28 16:14:08 misspiggy postfix/smtpd[16014]: warning: XXXXXXXXX.XXX.XXXXX.XXX[XXX.XXX.XX.X]: SASL PLAIN authentication failed: generic failure
Apr 28 16:14:11 misspiggy postfix/smtpd[16014]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
Apr 28 16:14:11 misspiggy postfix/smtpd[16014]: warning: SASL authentication failure: Password verification failed

You may need to tweak the permissions of the directory saslauthd is using.

On Ubuntu, that’s usually “/var/spool/postfix/var/run/saslauthd” (you can verify that path by typing “ps auxw | grep saslauthd”, and looking for the -m option).

Try this, for example:

chmod 711 /var/spool/postfix/var/run/saslauthd

And then restart saslauthd:

/etc/init.d/saslauthd restart

And Postfix:

/etc/init.d/postfix restart

ok…i check that and the permission on that saslauthd was 710. change it to 711 and restarted both of them and no change. One thing i notice, when i try to connect to the server it goes to port urd 465. if try to logon without using SSL or TLS, just to port 25 it still give me login error.

also, the email is not being send to the users. I send email to and when goes to the server it sends it, which that domain is not any on the server. It keeps tell me that MX record is not valid.

Okay, instead of 711, try changing it to 755.

Once you change the perms to 755, and restart both services, hopefully that will take care of it – and we’ll work through the rest of the outstanding issues at that point :slight_smile:

ok…i did that i tried both TLS and not encryption and this the response in the mail.log

postfix/smtpd[30990]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied

warning:[]: SASL PLAIN authentication failed: generic failure

I’ve got the same problem, and if I chmod the folder to 755, then restart asalauthd and postfix, it’s back to 710

Hmm, that shouldn’t be an issue on recent installations. But if you’re seeing that issue, you can typically resolve it with:

usermod -a -G sasl postfix

Then restart Postfix and Saslauthd.


Well, ‘recent’… This month, is that recent enough?

Anyway, I tried your suggestion but as soon as I restart saslauthd it’s back to 710 again.

Yeah, the 710 permissions are correct… and running the above command should ensure that Postfix/Saslauthd can properly read files within that directory.

After the above command, and restarting all the daemons, are you still having problems? If so, what error are you getting?