Postfix help

Hi, can someone please help me, as I am at the stage where I am severly pulling my hair out and going round the bend. I have my own vps set up and am trying to create a virtual server and configure the emails so I can access them and send using Thunderbird. I have come from cpanel and so do nut understand postfix and setting it up. I have read the forum and tutorials and am still baffled.
I have gone to create a new “website” and am now getting the following message;

Failed to create virtual server : No outgoing address mapping file (sender_canonical_maps) was found in your Postfix configuration

What does this mean and how do I fix this?

Did you use the Virtualmin installer script, or some manual/tutorial method? The former is highly recommended, since it will configure all services properly for you. The error you describe should not occur when you use the installer script on a clean OS install.

Hi, yes I used the automated script on a clean install.


Hmm, the error that you’re getting suggests that something non-default may be enabled.

What is the output of this command:

postconf -n

Also, do you receive any errors if you go into System Settings -> Re-Check Config?


alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
allow_percent_hack = no
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_protocols = all
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailbox_size_limit = 0
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
milter_default_action = accept
milter_protocol = 2
mydestination = $myhostname, localhost.$mydomain, localhost,
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
non_smtpd_milters = inet:localhost:8891,local:/var/run/milter-greylist/milter-greylist.sock
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sender_bcc_maps = hash:/etc/postfix/bcc
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_milters = inet:localhost:8891,local:/var/run/milter-greylist/milter-greylist.sock
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated check_policy_service unix:/var/spool/postfix/postgrey/socket
smtpd_sasl_auth_enable = yes
unknown_local_recipient_reject_code = 550
virtual_alias_maps = hash:/etc/postfix/virtual

is the output followed by:

No sender canonical map file for outgoing addresses was found in your Postfix configuration. You should either add the appropriate map to Postfix, or disable this feature in Virtualmin's module config page.

… your system is not ready for use by Virtualmin.

ok managed to get through the config check by changing;

Also update outgoing addresses for mailboxes? Yes No in the virtualmin config from yes to no.

which has allowed me to create a virtual server.

but thunderbird will still not connect to it

Please tell us more details, “will not connect” can have any number of reasons.

E.g., what error does Thunderbird show? What gets recorded in the mail log on your server when you try to connect?

Thunderbird is coming up with;

“Failed to find settings for the email account”

Okay, in that case you need to manually configure Thunderbird with the correct settings for your server. (Virtualmin can set up Thunderbird auto-configuration for your sites since a few versions ago though.)

Did you try that? Do you get other errors/problems?

right have turned off the mail client configuration in virtualmin and attempted to manually config using the thunderbird account settings but still getting same error.

I’m sorry, I don’t really understand the problem. The message that Thunderbird shows just means that it could not auto-configure for your server. It should then let you enter the server details manually. Can you post a screenshot of the error message and the configuration dialog?

do you mean in the log files or thunderbird. Maybe I am manually configuring it wrong but not used to this as always used cpanel before now and everthing just seemed so much more simple and automatic.

I’m confused… You were talking about a message Thunderbird showed you, “Failed to find settings for the email account”. This means auto-configuration is not available. Thunderbird should then offer you to configure the account manually.

Did you do that? What problems occurred then?

still could not connect to server and root emails not showing up, going to reinstall whole server again.

ok done a brand new install, not touched any postfix configs this time, just left as default, and Thunderbird can now connect kind of.

If I use thunderbird to send an email from my server domain to another email address it get delivered ok, if I then reverse the process and try sending through thunderbird to the domain it doesn’t arrive.


Hmm, I’m not sure I understand the difference between what is and isn’t working… however, whenever there are email problems, one of the best things to do is consult the logs.

You can find the logs in /var/log/maillog, or /var/log/mail.log, depending on your distro.

Using the logs, you can look for errors, as well as determine where exactly it is that the emails are going.


hi, right email is setup for user on domain.
I use Thunderbird to connect to the server and retrieve any emails sent to the domain and also to send email from the domain ie

Now Thunderbird has connected to my vps and and is accesing

If I use thunderbird to send a message from it sends it to the server and promptly gets delivered to the intendend person no matter where in the world they are.
The problem is if said other person then replies to my sent email it is not arriving at my vps and so thunderbird can’t download it and let me read it.
have looked in logs but nothing makes sense to me.

So in other words the server isn’t accepting incoming mail

First step would be to ask the “other person” if they get a non-deliverable message back, saying if and why their mail couldn’t be delivered. Usually you have errors like “target server not responding”, “mail denied for reason X” or so in that report.

Without any information from the sending side all we could do is guess what could be wrong.

ok, i’ll wait for that to come back then repost here.

ok getting the following on returns;

connect to[...]:25: Connection timed out