Postfix Dead, ClamScan Hanging?

OS type and version Ubuntu Server 22.04.1
Webmin version 2.013
Virtualmin version 7.5
Postfix 3.6.4

Postfix seems to have dropped dead without my knowing it. Whenever I try to restart it, the server chokes up to almost 100% utilization of CPU, RMem, and VMem. After which, warnings like this dump out on the console:

I can’t get it going again. What’s happened here??

As per the error message, you’re out of memory. How much memory do you have on the server?

1 Like

8GB. Which I don’t recall being a problem before… nothing else is running. Basic, vanilla virtualmin install, serving some email.

Hm, that should be more than enough.
Then you should find out what’s using all the memory. But if nothing pops out, reboot?

Memory and CPU usage is totally nominal until trying to start the Postfix server back up. Then there’s a huge spike (full CPU/RMem/VMem usage). This sustains for about 30 seconds, until the Ubuntu kills either Clamd or Clamscan (you can see this in the screenshot).

I bumped the VMWare memory for this VM up to 16 GB (huge overkill). Booted up, tried to launch Postfix — and then “it,” whatever “it” is, promptly sucked up 100% of CPU, and almost 60% of Rmem/VMem (which worked out to about 9.28 GB).

(To clarify, these are the reads I’m seeing on the Webmin Dashboard.)

This attempt succeeded in regaining postfix, but … I feel that I should NOT be needing 16GB of RAM assigned to a Ubuntu VM running vanilla Virtualmin just to launch postfix. Something is catawampus here.

try removing clamav alltogether, or just removing it from virtualmin…
or check postfix logs to see what’s the error…

You don’t need to remove it. Just stopping the clamd service (and disabling AV scanning in Virtualmin) is sufficient to stop paying the ClamAV memory/CPU price (which is very high…about 1GB of memory is needed for ClamAV).

But, nothing operating normally in a Virtualmin system needs 8GB or 16GB.

Something is pathological about the configuration here…though I’m having a hard time guessing what. I’ve never seen Postfix consume more than a few hundred MB (and even that is shockingly large…postfix is normally tiny).

Shutting down ClamAV and disabling AV scanning would be a good first step, just to rule it out.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.